Results 1 to 4 of 4

Thread: Startup Delay

  1. #1
    Join Date
    Oct 2007
    Posts
    11

    Default Startup Delay

    Startup in build 442 seems much slower than in previous releases. I even switched from full debug to optimised build to check, but still the same.

    Actually, I think the problem is not that it's slower, but that it "seems" slower because the window isn't populated until the analysis is complete (i.e., until the "Stop Loading" button stops flashing), whereas before the comparison windows would be populated while this was still flashing.

    I think the previous behaviour is much better, and I would have this as the default option (if it is switchable).

    Is there an option to switch between both implementations? I couldn't find one.

    (This is when diffing two files through SubVersion and Code Co-op.)

  2. #2
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    2,503

    Default

    In the file comparison "Session Settings" dialog, switch to the "Alignment" tab and make sure the "Standard method" radio button is selected. It supports outputting the alignment as it's done, unlike the "Alternate method".
    ZoŽ P Scooter Software

  3. #3
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    2,503

    Default

    Nevermind, I'm seeing it too. It looks like reading the file formats got slower; we cache part of them and at least on my system the slowdown doesn't occur if I already have a Cirrus window open.
    ZoŽ P Scooter Software

  4. #4
    Join Date
    Oct 2007
    Posts
    11

    Default

    Thanks, Craig.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •