Results 1 to 5 of 5
  1. #1
    Join Date
    Jun 2009
    Posts
    5

    Default Ignore single/double quote marks in HTML

    How can I get BC3 to ignore differences of only '/" within HTML files?

    eg, ignore :-
    left : <ul class="group">
    right : <ul class='group'>

  2. #2
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    11,384

    Default

    Hello,

    The mark the difference between ' and " only when they are aligned as unimportant, the method would be to use the BC3 Pro feature Text Replacements, in the Text Compare's Session menu, Replacements tab. Define two new replacements, " = ' and ' = " (both directions).

    You can also add this as default Text Compare behavior in the Home screen, Edit session defaults folder, Text Compare, Replacements tab.
    Aaron P Scooter Software

  3. #3
    Join Date
    Jun 2009
    Posts
    5

    Default

    Thats the ticket, it works!
    Thanks a lot.

    See also http://www.scootersoftware.com/vbull...4026#post34026

  4. #4
    Join Date
    Jul 2016
    Posts
    1

    Default

    Thank you all for this trick. I had an issue with it though. I was doing a folder compare, and all single quotes were replaced with double. So I used the trick mentioned above, so when i would open the different file, the text editor would show no differences. However there are so many other files. For now I went through them all manually, but is there a way so folder compare can see the single/double quote as same?

  5. #5
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    11,384

    Default

    Hello,

    Yes, if double clicking opens and shows the file as equal because the defaults are pre-configured, then you can set the Folder Compare's Session menu -> Session Settings, Comparison tab: leave defaults Timestamp/Size/Override and also enable Rules-based comparison. This "double clicks" all of the files in the Folder Compare by running a rules-based scan.
    http://www.scootersoftware.com/suppo...ferentthensame


    If the Text Compare requires altering settings when you double click to view, then we'll need to update your Text Compare default session settings. You can do this by double clicking one file, altering the settings in the child compare, but before clicking "Ok" on the Session Settings dialog, update the dropdown from "use only for this view" to either "use for all files in parent session" or "also update session defaults".
    Aaron P Scooter Software

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •