Results 1 to 4 of 4
  1. #1
    Join Date
    Sep 2011
    Posts
    3

    Default Using public/private key authentication with SFTP

    I'm trying to setup a SFTP connection in BC3 and no matter which key file I load it keeps asking for my password and won't connect.

    I do know it's setup properly. I have WinSCP installed and can load the private key (PuTTYs PPK file) and put in the passphrase or keep Pageant running and it will do the authentication for me.

    I know I must be missing something and maybe I'm the only one trying to do this in Windows 7 (instead of Linux). Any help would be greatly appreciated. Thank you in advance.

  2. #2
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    2,507

    Default

    Just leave the password blank, check "Remember password", and click "Ok". BC asks for the password before it tries to connect, so it doesn't know whether it's necessary.
    ZoŽ P Scooter Software

  3. #3
    Join Date
    Sep 2011
    Posts
    3

    Default

    Hahaha thanks, thought I was going crazy! That did the trick.

  4. #4
    Join Date
    Sep 2011
    Posts
    3

    Default

    Ok that works, I'm using the key and passphrase to log in and everything but a heads up, when you don't save the passphrase (with the intention of having to type it while logging in) it comes up with the user and password prompt again not the passphrase. I'm not sure if this is by design but if I didn't want to save my passphrase for every use it wouldn't work.
    Last edited by Cwluc; 21-Sep-2011 at 09:20 PM.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •