Results 1 to 2 of 2
  1. #1
    Join Date
    Apr 2011
    Posts
    1

    Default How to ignore newlines encoding?

    I was testing the BC3 with a folder and the same folder downloaded from a remote server and I was surprised because most of the files in the folder were red highlighted as "different".

    But when I selected them and click on "quick compare" or "diff compare", it says that the two files are identical (and they look as identical).

    I also noticed that the files had different size, so I think that the problem is that the text files have been modified during the FTP so they had different newline encoding (Win vs Unix).

    How can I make that the BC3 folder comparation ignore the size difference in text files that are identical but their newlines?

    thanks

  2. #2
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    11,384

    Default

    Hello,

    We actually have a couple KB articles that help with this topic. Here is a general KB on why the comparison changes after viewing or content comparing your files (quick summary: by default we run Timestamp/Size Comparisons, but if a more detailed scan is run we will update the file comparison info).
    http://www.scootersoftware.com/suppo...ferentthensame

    And here is an article on FTP comparisons and file size changing:
    http://www.scootersoftware.com/suppo...b_ftpdifferent

    You can make BC3 ignore the file size by going to the Session menu -> Session Settings, Comparison tab, and disable the File Size as part of the comparison. This would run a Timestamp only comparison. Alternatively, you can also enable one of the more detailed scans (binary, crc, or rules-based) if you would like a more detailed scan beyond just checking the timestamp.

    Does this help explain the behavior you are currently seeing? Please let us know if you have any questions.
    Aaron P Scooter Software

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •