Page 1 of 2 12 LastLast
Results 1 to 10 of 14
  1. #1
    Join Date
    Oct 2009
    Posts
    2

    Default "Ignore line endings" is being ignored

    I have a session set up with rules that say to ignore line endings (I'm comparing DOS vs Windows files), and when I compare lots of files, they all show that they are different. However, when I double click on any of them, the file viewer that opens shows that there are no differences (except the line endings).

    Now when I dismiss the viewer window, the main results window changes the file from 'different' to 'not different' (toggling "Ignore unimportant differences" brings it back, toggling it again removes it).

    I want the initial results window to set files that only have line endings differences to be listed as "the same except for unimportant differences" (specifically, line endings).

    Is there a way to configure BC3 to do this?

    I'm running BC v2.5.2 (build 252)

  2. #2
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    11,788

    Default

    Hello Andy,

    The issue is that the Directory Viewer uses Timestamp/Size for the comparison initially as the default. You can change this by going to the Session menu and changing your Comparison Criteria to use Rules-based content comparison.

    Then use the Session menu to Set Defaults if you want to use this for all future Directory Viewer comparisons, or save that specific session for future use.
    Aaron P Scooter Software

  3. #3
    Join Date
    Oct 2009
    Posts
    2

    Default

    Awesome!! Worked like a charm. I've been living with this issue for months and finally posted it here. Wish I had done it sooner.

    Thank you very much!

  4. #4
    Join Date
    Jul 2009
    Posts
    11

    Default

    Where is the option to 'Ignore line endings'?!! I can't find it anywhere in the Session settings or File Formats dialog...

    Even weirder, I seem to have been able to setup my session to do just that, since it marks the files as the same, but they are still displayed in red and are showing in the viewer, even with 'Ignore unimportant differences' switched on - see screenshot.

    http://screencast.com/t/NzA4MWQyNz

    AHA, Ben

  5. #5
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    11,788

    Default

    Hello,

    From your screenshot, it looks like you have a black equal sign in the center column, indicating your files are rules-based equal. They may still be red due to your current settings. Try going to the Session menu -> Session Settings, Comparison tab. Is Override Quick Test Results enabled? Try enabling it if it is not. That should make the center column's findings (equal) override the other quick tests (timestamp is different).
    Aaron P Scooter Software

  6. #6
    Join Date
    Jul 2009
    Posts
    11

    Default

    Hi Aaron, that works, thanks

    I'm still confused about where the 'Ignore line endings' setting is though, I've seen it mentioned many times in the forum but I can't find it anywhere?

    Cheers, Ben

  7. #7
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    11,788

    Default

    The option is actually called "Line Endings" in the Unimportant section of the Importance tab of your specific Rule. If it is grayed out, you need to enable Whitespace Includes: Line Endings (PC/Unix/Mac) on the General tab.

    This will mark the Line Ending character as unimportant, so if the file was formatted on a PC on one side, and a Mac on the other side, it will mark the different Line Ending characters as unimportant. This does not change where line breaks occur. The issue it is designed to resolve is that PC's use a different character to differentiate a line break. This is technically a difference that can be ignored, hidden or compared. If you enable Show Whitespace, you can see the Line Ending characters (we use 3 different symbols for the different OS Line Ending characters). If the symbols are different, the file sizes can be different, while the text inside is the same. Enabling this option allows you to compare the text, ignore the line ending and file sizes, and still mark the files as equal.
    Aaron P Scooter Software

  8. #8
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    11,788

    Default

    This assumes you are using BC2. In BC3, the same settings can also be controlled and found in the Session Settings dialog.
    Aaron P Scooter Software

  9. #9
    Join Date
    Jul 2009
    Posts
    11

    Default

    Hi Aaron, I'm using BC3, I can't see these anywhere in the Session Settings dialog. Which tab are they on?

  10. #10
    Join Date
    Oct 2007
    Location
    Pennsylvania
    Posts
    1,772

    Default

    From a text compare session, look on the Importance tab, Miscellaneous section
    BC v4.0.7 build 19761
    ¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •