Results 1 to 3 of 3
  1. #1
    Join Date
    Jan 2008
    Posts
    32

    Default AS400, iSeries, System i FTP

    Hi,

    Just thought I would pass along some info to anybody attempting to use BC3 with a AS400, iSeries, System i (or whatever IBM's name dejour is...).

    With Windows Command-Line FTP, I would normally issue a "QUOTE SITE NAMEFMT 1" command after connecting, but how do I get BC3 to do this?

    First, I found that you can add any special commands you want via the "FTP Profile -> Custom Login Commands", but they are set without the "quote" statement, so the above becomes simply "SITE NAMEFMT 1".

    Great! However, after much testing I found I still could navigate to /QSYS.LIB/QGPL.LIB without an error.

    Again after much testing I found the LISTFMT needs to be set to "1" using this command "SITE LISTFMT 1". I then actually removed the NAMEFMT command and all is good.

    Two other things to note:

    1. When navigating to a Library containing SAVF files, they have a ".SAVF" extension NOT ".FILE" like you see in the Command-Line FTP client.
    2. When you transfer these SAVF files, they will have a different a different size than on the System i. To check, I downloaded the same files via Command-Line FTP and did a binary compare against the same file downloaded via BC3 and found they are the same. So I know there's not a conversion issue.


    Hope this helps somebody else out there.

    And oh by the way, to the entire Scooter/BC3 team from a long time power user -- Your product ROCKS!!!

    Mark

  2. #2
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    12,003

    Default

    Thanks for the info an compliments! It looks like you spent some time troubleshooting this yourself for awhile.

    Let us know if you run into any other issues, or have any quesitons.
    Aaron P Scooter Software

  3. #3
    Join Date
    Jan 2008
    Posts
    32

    Thumbs down

    UPDATE:

    My original post was good enough for binary files (in my case "SAVF" files), however when I recently went to transfer some data files it became clear something wasn't quite right.

    The problem was normal AS400 physical files need to be translated from EBCDIC to ASCII. If the transfer is in ASCII mode, the AS400's FTP server will automagically take care of this for you.

    To make this happen via BC3, I opened up the FTP profile, clicked on the "Transfers" tab and added *.file & *.mbr to the "ASCII Types" box. Reinitiated the connection and BOOM! Transfers completed properly!

    It should be noted that with BOTH ASCII AND Binary transfers I have seen file size differences (though not always on binary). Not sure why there is sometimes a difference on binary but after MANY transfers I can only say I've had no problems to date.

    God I love this product!
    Mark

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •