Results 1 to 5 of 5
  1. #1
    Join Date
    Jun 2009
    Posts
    1

    Default BC3 and Fedora 11 x86_64

    Capturing this info for someone else out there. If you have a Fedora 11 (Leonidas) 64-bit install and you need the Beyond Compare tool, then
    1. Get the latest BC3 available from Scooter Software
    2. sudo yum install qt3.i586
    3. cd [Download/untar directory]/bcompare* ; sudo install.sh
    4. sudo yum install compat-libstdc++-33.i586
    5. sudo yum install qt3-config.x86_64

    After that, you should be good-to-go. The last most item is not required, but will allow some configuration of the BC3 interface. You may experience some text-clipping with the default font, for example.

  2. #2
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    11,373

    Default

    Thanks, szf!

    Help with different walk-throughs and 64bit installs is always appreciated.
    Aaron P Scooter Software

  3. #3
    Join Date
    Jan 2009
    Location
    Broadway, UK
    Posts
    7

    Default problem with libqt-mt.so.3

    Having moved to fedora after running into problems with suse, mandriva and a few other distributions on the way ... I found fedora11 installed almost everything in a format I liked, using just old enough versions to not have problems, and apart from a niggle with graphics I was running very quickly.
    I've come to reinstall BC as I really do find it a very useful compliment to Eclipse but hit a snag. The above seemed to work fine, but BC will not start -
    Some Shared Libraries were not found
    libqt-mt.so.3 => not found
    Everything else looks fine, and there is a copy of the libqt-mt.so.3 link to 3.3.8, but both 32bit and 64 bit versions are present. I don't think this should be a problem, but can't understand why BC can't find the 32 bit one when it's seeing the other libraries in the same place!
    --
    Lester Caine - G8HFL
    -----------------------------
    Contact - http://lsces.co.uk/lsces/wiki/?page=contact
    L.S.Caine Electronic Services - http://lsces.co.uk
    EnquirySolve - http://enquirysolve.com/
    Model Engineers Digital Workshop - http://medw.co.uk//
    Firebird - http://www.firebirdsql.org/index.php

  4. #4
    Join Date
    Jan 2009
    Location
    Broadway, UK
    Posts
    7

    Default problem with libqt-mt.so.3 - sussed

    libqt-mt.so.3.3.8 is in a qt3 sub-directory, which seems to be the problem. I've bodged things for the moment, and copied it to the private beyondcompare library folder. When I looked at the startup script, the problem was fairly obvious, but I'm not sure how to fix it correctly!
    Anyway - I'm doing the job that I NEEDED BC in oreder to complete
    --
    Lester Caine - G8HFL
    -----------------------------
    Contact - http://lsces.co.uk/lsces/wiki/?page=contact
    L.S.Caine Electronic Services - http://lsces.co.uk
    EnquirySolve - http://enquirysolve.com/
    Model Engineers Digital Workshop - http://medw.co.uk//
    Firebird - http://www.firebirdsql.org/index.php

  5. #5
    Join Date
    Apr 2010
    Posts
    1

    Default

    64 bits feasible...sounds great..
    -----------------
    testking JK0-016 For Help testking HP0-J38For Knowledge testking 70-653 For Study
    testking 70-663
    Last edited by nighthitcher; 04-Nov-2010 at 07:12 AM.
    smith

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •