Results 1 to 5 of 5
  1. #1
    Join Date
    Jun 2009
    Posts
    3

    Default Shortcut bug in BC3 3.1.3 (build 10374)?

    I think this is a bug. It's definitely different from a previous build I used. And it's annoying.

    Note: I have BC3 keybindings reconfigured to use F7 for 'previous difference section' (instead of Ctrl+P) and F8 for 'next difference section' (instead of Ctrl+P) -- perhaps that's relevant.

    Here we go:

    1. Open a folder compare against two folders with just a few files in them. Let's say 1 of the files is different and that it has a few sections in them that are different.
    2. BC3 will show you the list of files. I have my BC3 set up to compare using rules so it will compare right when it opens.
    3. Highlight the the file with the differences and hit ENTER to open a file compare session in a separate tab
    4. Try to navigate forward to the next different section (Ctrl+N) -- that seems to work. Now try to navigate backwards to the first section (Ctrl+P) -- here it doesn't work.


    Other shortcuts/keystrokes also seem to have problems. After some observation, it seems that BC3 is getting confused and is redirecting some of the shortcuts/keystrokes input to the first tab instead of the current tab. For example, after I hit F7 and I see it didn't work, I just hit Escape to go back to the first (folder compare) tab and I notice that the mouse cursor changed to an arrow with a question mark and the current file is highlighted in light green which incidentally means BC3 captured my F7 as 'Compare To...' (under the Actions menu). In summary, not all keystrokes are being sent to the correct tab -- some are being sent to the first tab instead.

    Note that this bug doesn't seem to affect interactions with the mouse. It only seems to affect interactions with the keyboard.

    Has anyone else seen this? Is this a known issue?

    Thanks,
    Bruno.

  2. #2
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    2,519

    Default

    Hi Bruno,

    We had another customer report something similar in Windows 7 here, and I can reproduce it there, but not under Vista. Are you using Win7?
    ZoŽ P Scooter Software

  3. #3
    Join Date
    Jun 2009
    Posts
    3

    Default

    Ah, good point. Yes, I'm using Win7 RC (build 7100). Sorry I forgot to mention that.

  4. #4
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    2,519

    Default

    I've found the problem and it will be fixed in the next release. For now you should uncheck the "Show previews for individual tabs in the taskbar" option on the Options dialog's Tabs page.
    ZoŽ P Scooter Software

  5. #5
    Join Date
    Jun 2009
    Posts
    3

    Default

    Excellent! Just tried the work around and it does seem to work.

    Thank you for the quick response. Will keep an eye out for the "An update is available" link in BC3.

    Thanks,
    Bruno.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •