Page 1 of 3 123 LastLast
Results 1 to 10 of 21
  1. #1
    Join Date
    Jun 2005
    Location
    Stockholm, Sweden
    Posts
    192

    Default Number of problems after migrating from BC2

    Our company has just upgraded from BC2 to BC3 and I'm seeing a number of problems. One of my main usages of BC is to compare cobol code on the PC with ditto on z/OS (keep in mind that we're a Swedish company). FORTUNATELY, I'd written a "dummies" document for new users of BC2 so when I started receiving problems, I referred to this document.

    My first attempt was to try and compare a PC folder with one on the mainframe (MF). I'd forgotten whether I needed to specify the fully qualified "folder" name on the MF so I started by specifying the MF folder as userid.xxxx.yyyy. This was rejected (fair enough), so I changed it to 'userid.xxxx.yyyy' (note the quotes) and was able to bring up the folder contents. Next problem - in BC2, I'd specified that any files ending in CBL or COBOL (if I remember correctly) caused a prompt for the code page conversion. This would be ANSI for the PC, and 1143 for the MF - this worked fine. Now to my problems.

    I started by comparing 2 files, PC on the left, MF on the right. The MF file was shown as garbage. I noticed the pulldown as shown in BC3_screen1 - trouble is, when I expanded this for the MF files, 1143 Finnish/Swedish wasn't one of the options (which it was in BC2). I changed the option to Western European but that didn't help. I thought that this was the type of change that required closing/restarting BC, so I tried that. Now the situation got worse - when I selected the same session again, I got the results in BC3_screen2 and couldn't access the MF at all. Okay, I thought - my password has possibly been saved incorrectly (even though I deliberately unticked the box to save the password). I looked in my old BC2 notes and saw the following:_

    Clearing your password if it’s saved by mistake

    If by some chance, your password gets saved (thereby resulting in you never being prompted for it when you open TSO as an FTP site) you can clear/remove it in the following manner.

     Start BC and access some TSO PDS
     Select tools, options, and the FTP firewall/proxy option on the left-hand side
     Click on the Clear passwords button
     Select OK

    Trouble is - that option seems to have been changed/moved somewhere else.

    Final "complaint". I have defined some rules for cobol code (saved in an XML file) and tried to import these rules. I received the error message "BC2 rules not importable". I'm ASSUMING there's a way to convert old rules and import them, or ...........
    Last edited by misi01; 09-Apr-2010 at 12:28 AM.

  2. #2
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    4,728

    Default

    Character Encoding Pulldown:

    The dropdown in your screen shot only lists a subset of common character encodings. To see the full list, select Session > Session Settings. Go to the Format tab. Select an "Encoding override". You can choose between "Use for this view only", "Use for these files within parent session", "Use for all files within parent session", or "Update session defaults" at the bottom of the dialog, then click OK.

    If you always want a specific file extension to open using your preferred character encoding, select Tools > File Formats. Select a File Format, then go to the Conversion tab. Change the Encoding from "Detect" to your preferred encoding.

    Clearing Passwords:

    To clear a saved FTP password, select Tools > FTP Profiles. Select the profile for your FTP server. In the General tab, uncheck "Save password" and delete the password text.

    Importing BC2 Rules:

    It isn't possible to import BC2 rules into Beyond Compare 3. If you need help recreating BC2 rules in BC3, you can email the XML file to support@scootersoftware.com and we'll try to help you convert them.
    Chris K Scooter Software

  3. #3
    Join Date
    Jun 2005
    Location
    Stockholm, Sweden
    Posts
    192

    Default More on this

    Thanks Chris for the reply. Hmmmm. To see the full list, select Session > Session Settings. Go to the Format tab. Assuming we're on the same page, there is no format tab. Attached a screen capture. I selected Sessions, Session settings in the top left-hand corner.

    Clearing passwords - thanks, that did the trick. You have to remember to untick the save passwords the next time you run it though.

    Character encoding. Enclosed is another screen capture taken from Tools, FTP profiles, and the General tab. I assume this is what you meant (rather than File formats) ?????

    Finally, cannot get at any MF files in BC3. Does this log screen capture help/explain ?
    Last edited by misi01; 09-Apr-2010 at 12:28 AM.

  4. #4
    Join Date
    Oct 2007
    Location
    Pennsylvania
    Posts
    1,772

    Default

    The Format tab is under Session Settings for a text compare or a data compare session, not a folder compare session.

    Open a compare session on a file pair that exhibits the encoding problem.
    Click on Session Settings \ Format tab.
    Select the desired encoding override.
    Choose "Also update session defaults" if you want to apply the override to all new sessions of that type.
    Click OK.
    BC v4.0.7 build 19761
    ¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯

  5. #5
    Join Date
    Jun 2005
    Location
    Stockholm, Sweden
    Posts
    192

    Default Sorry Michael, but that's cheating

    Let me clarify again. In BC2, I selected folder compare, selected a folder on the PC and a mainframe PDS (sort of like a folder - contains a number of separate files). In BC2, I'd set up my session such that cobol files always prompted me for the conversion code, ansi for the PC, 1143 for the mainframe. All well and good.

    Saying that I should select the format option for a text compare doesn't help me since I can't select an FTP object that way (can I ?).

    Back to you.

  6. #6
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    11,893

    Default

    Hello misi01,

    This is a Session specific setting. You should have a Saved folder compare session comparing your PC to your Mainframe. Open this session and then open a pair of files exhibiting this issue. Once open in the Text Compare, go to the Session menu -> Session Settings -> Format tab. Here, at the bottom, is an Encoding Override (like the Prompt in BC2). Pick the appropriate encodings for the left and right side. Then change the dropdown in the bottom left to "Apply for All files in Parent Session". The parent session is your Saved folder compare session, which you will want to now re-save to apply these settings.

    Now every Text Compare you open in the Parent Folder Compare should apply the encoding overrides, and you will not need to be prompted each time.

    Let us know if you are still having trouble or have any questions.
    Aaron P Scooter Software

  7. #7
    Join Date
    Jun 2005
    Location
    Stockholm, Sweden
    Posts
    192

    Default Thanks Aaron

    will try it on Monday at work.

  8. #8
    Join Date
    Jun 2005
    Location
    Stockholm, Sweden
    Posts
    192

    Default Aaron - I think you're going to have to treat me like an idiot.

    You should have a Saved folder compare session comparing your PC to your Mainframe. Open this session and then open a pair of files exhibiting this issue.

    I managed to find a topic elsewhere whereby I could download a version of BC2. I include below a screen capture showing what happens when I compare a PC folder with a MF one. As you can see, no problem. When I do the same thing in BC3, I get the second screen capture from my first append, ie, I don't even get to see ANY files on the MF.

    Following on...
    Once open in the Text Compare, go to the Session menu -> Session Settings -> Format tab.
    Isn't that the same advice as Michael offered. When I try the following, Start BC3, select Text compare, I get the second attached screen capture. Where do I select an FTP folder there ????

    Sorry to be a PITA, but as a user whose migrated from BC2 to BC3, I expect new bells and whistles, but I also expect to be able to use the knowledge I have from the previous version and apply it to the new one and not have to jump through a load of hoops to get where I already was in BC2.
    Last edited by misi01; 09-Apr-2010 at 12:28 AM.

  9. #9
    Join Date
    Jun 2005
    Location
    Stockholm, Sweden
    Posts
    192

    Default Finally got the connection to the MF to work

    I'd changed the Tools, FTP profiles, default encoding setting to 1143 (Swedish, Finnish). Seemed logical to me, but that was what was screwing up the MF member download. After changing it back to ANSI, I can now see the MF PDS members in the right hand side.

  10. #10
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    2,524

    Default

    Quote Originally Posted by misi01 View Post
    I'd changed the Tools, FTP profiles, default encoding setting to 1143 (Swedish, Finnish).
    There's actually two encodings involved here. The one in the FTP profile only controls the encoding used for paths and directory listings when you're communicating with the server, and doesn't have anything to do with the encoding of the files. The file formats and session settings the others have mentioned control that.
    Zoë P Scooter Software

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •