Results 1 to 2 of 2
  1. #1
    Join Date
    Oct 2008
    Location
    Michigan
    Posts
    2

    Unhappy Diff's frequently fail with Perforce

    I use The Perforce Windows Client for my version control. I have set BC3 up as my diff tool. Frequently, when there is a decent load on my system (compile, etc.), when I run "diff against depot" to compare my local checked out version of a file with a version on the server, the diff fails.

    The perforce client pulls a copy of the file on the server and stores it to a local temp directory, then passing this file name and the local file to the diff tool. BC3 then reports that the temp file doesn't exist.

    I'm not sure if the perforce client is executing the diff before the file exists or there is a locking issue, but this problem never happened with BC2. And when I am having the issue, if I swap the diff tool back to BC2, the problem immediately goes away.

    I am running Perforce Windows Client (P4Win) Version 2007.3.147477, P4 server P4D/FREEBSD60X86/2007.3/152469 and BC Version 3.0.9 (build 9222)

  2. #2
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    2,519

    Default

    Make sure that you're using "bcomp.exe" instead of "bcompare.exe". The first one waits for the comparison to complete before exiting, so it handles this case.
    ZoŽ P Scooter Software

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •