Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: FTPS Issue?

  1. #1
    Join Date
    Aug 2008
    Posts
    6

    Question FTPS Issue?

    In the past (before i upgraded today to the latest bc3 - 8706) I had been able to connect to my windows server 2008 machine running the ftps server in IIS7.

    Now I get:
    8/20/2008 1:58:26 PM Stat> Connected.
    8/20/2008 1:58:26 PM Recv> 220 Microsoft FTP Service
    8/20/2008 1:58:26 PM Sent> AUTH TLS
    8/20/2008 1:58:26 PM Recv> 234 AUTH command ok. Expecting TLS Negotiation.
    8/20/2008 1:58:26 PM Sent> QUIT
    8/20/2008 1:58:26 PM Stat> Disconnected.
    8/20/2008 1:58:26 PM Connection Closed Gracefully.

    Note that we are immediately sending a QUIT, rather than proceeding with login.

    Any insight?

  2. #2
    Join Date
    Jan 2007
    Posts
    3

    Default FTPS Issue - me too

    I have the same setup: Windows Server 2008 - IIS 7.0 FTP/SSL and can't get FTPS (Explicit SSL) to connect. I have a log from a working connection

    220-Microsoft FTP Service
    220 WELCOME TO xxxxxxxx
    COMMAND:> AUTH SSL
    234 AUTH command ok. Expecting TLS Negotiation.
    STATUS:> Negotiating SSL connection with server.
    STATUS:> SSL connection established. All transactions are now secure.
    STATUS:> Connected. Logging into the server
    COMMAND:> HOST xxxxxxxxxxxxxxxxxx
    220 Host accepted.
    COMMAND:> USER xxxxxxxxx
    331 Password required for xxxxxxxxx.
    COMMAND:> PASS ****************
    230 User logged in.
    STATUS:> Login successful
    COMMAND:> SYST


    It appears that a successful connection sends a HOST command prior to the USER command. BC seems to be sending just the USER command.

    Any help would be appreciated - thanks.

  3. #3
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    4,794

    Default

    Thanks for reporting the problem. I'll setup an IIS7 FTPS server here and try to figure out why it isn't working.
    Chris K Scooter Software

  4. #4
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    2,531

    Default

    eedwards,

    We've implemented "HOST" support for the next release, which should fix meeque's problem, but based on your log I'm not sure it applies to you. Which version of BC were you using prior to upgrading? You didn't mention if any other FTP clients are able to connect. If they are, are they sending the HOST command (immediately before USER), and if so, if you disable it do they stop connecting?
    ZoŽ P Scooter Software

  5. #5
    Join Date
    Jan 2007
    Posts
    3

    Default

    Craig;

    Beautiful - works like a charm!
    Thanks so much!

    Mark

  6. #6
    Join Date
    Aug 2008
    Posts
    6

    Default

    @Craig

    What ftp clients might support ftps? I wasn't aware of many others that do.

  7. #7
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    2,531

    Default

    There are actually quite a few, though I can't comment on most of them. Mark (meeque) is using FTPVoyager and it supports enabling/disabling the "HOST" command, which would allow you to test whether that's the issue. Filezilla, CoreFTP, and CuteFTP also all support FTP over SSL.
    ZoŽ P Scooter Software

  8. #8
    Join Date
    Aug 2008
    Posts
    6

    Default QUIT?

    This is the part that puzzles me:

    8/20/2008 1:58:26 PM Recv> 234 AUTH command ok. Expecting TLS Negotiation.
    8/20/2008 1:58:26 PM Sent> QUIT

    What in the code would cause BC3 to send QUIT after recieving AUTH?

    Is there something certificate related (but not logged?)

  9. #9
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    2,531

    Default

    It's likely some sort of problem with the TLS handshaking. In your original post you mentioned that it worked prior to upgrading to 8707. Do you have any idea which version you were using prior to that?
    ZoŽ P Scooter Software

  10. #10
    Join Date
    Aug 2008
    Posts
    6

    Default

    i am pretty sure i was just on the version just before 8707. I had just installed bc3 fresh after purchase, then a week later 8707 came out. So whatever came before 8707 was what I was on.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •