Results 1 to 9 of 9

Thread: Column Compare

  1. #1
    Join Date
    Oct 2007
    Location
    Pennsylvania
    Posts
    1,772

    Default Column Compare

    I believe that the ability to perform a column-based compare and/or merge is on the BC wish list...
    In the mean time, what would the best way to eliminate the column of date-time stamps from the following text compare?

    http://mysite.verizon.net/bulgrien/j...umnCompare.png

  2. #2
    Join Date
    Oct 2007
    Posts
    786

    Default

    You can define a File Format for your log files, and add a grammar item that classifies the first 21 columns as a Timestamp. Then your session rules can set Timestamps as unimportant.
    Tim T Scooter Software

  3. #3
    Join Date
    Oct 2007
    Location
    Pennsylvania
    Posts
    1,772

    Default

    Sounds simple enough...so forgive my ignorance...

    I created the File Format and the "Timestamp" Grammar Rule:
    http://mysite.verizon.net/bulgrien/j...FileFormat.png

    But the "Timestamp" Grammer Rule does not show up in my Session Settings Importance list:
    http://mysite.verizon.net/bulgrien/j...onSettings.png

    Edit: I had to close and relaunch Cirrus for the grammar rule to show up. I wouldn't think this should be necessary.
    Last edited by Michael Bulgrien; 10-Mar-2008 at 01:43 PM.

  4. #4
    Join Date
    Oct 2007
    Posts
    786

    Default

    Yes, it should show up immediately. We'll try to get that fixed.
    Tim T Scooter Software

  5. #5
    Join Date
    Oct 2007
    Posts
    437

    Default

    Actually, I'd guess the reason you're not seeing "Timestamp" in the "Importance" list is because you're not using your "COM+ Log Files" format.

    Elements are only shown in the "Importance" list that are defined in the format(s) that are in use.

    Cirrus will not automatically switch detected formats in an open session. Choose "Reload Files" from the "Session" menu to do so.
    Erik Scooter Software

  6. #6
    Join Date
    Oct 2007
    Location
    Pennsylvania
    Posts
    1,772

    Default

    Quote Originally Posted by Erik View Post
    Actually, I'd guess the reason you're not seeing "Timestamp" in the "Importance" list is because you're not using your "COM+ Log Files".
    Actually, I was using my new file format. I double and triple checked it. As I specified above, the new grammer rule did not show up in the list until I restarted Cirrus.

  7. #7
    Join Date
    Oct 2007
    Location
    Pennsylvania
    Posts
    1,772

    Default

    As further clarification, I had selected the new file type, but I had not performed a manual reload of the files. In my opinion, a "reload files" should not be necessary to see a new grammar rule in session settings. When a new grammar rule is created, it should be applied (via a programmatic reload) just as is done when one selects a different file type from the "Rules" drop-down list.

  8. #8
    Join Date
    Oct 2007
    Posts
    437

    Default

    You mean format type, not file type right?

    Please list the specific steps you are taking.
    Erik Scooter Software

  9. #9
    Join Date
    Oct 2007
    Location
    Pennsylvania
    Posts
    1,772

    Default

    Erik, I see why you're confused. I can't reproduce the issue either. I'm not sure what I did the first time...I do know that I did the steps in a round about way (created a new file format, then renamed it, etc) but when I delete the file format and create it again from scratch, everything works as expected. Weird. Anyway, since everything works fine when I perform the steps in a logical order, you can disregard this reported issue. If I ever figure out how I did it the first time, I'll be sure to post the steps.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •