Results 1 to 5 of 5
  1. #1

    Default Says files are different but they aren't

    Hi,
    I'm doing a folder compare and although it says the files are different, when I open them they are not. The file stamps are different but Compare timestamps is not checked. Any ideas? TIA!

  2. #2
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    11,623

    Default

    Hello,

    What is checked in the Folder Compare, Session Settings, Comparison tab? Timestamps is verified unchecked? Is Size? Something must be checked that is also different.

    Double clicking is running a Rules-based scan, which you can enable on the Folder level to see similar results:
    http://www.scootersoftware.com/suppo...ferentthensame
    Aaron P Scooter Software

  3. #3

    Default

    If I have all options unchecked it does not pick up files that do have differences - in this case php files.

    If I go back and check Compare file size it says all files are different.


    Also, this is SFTP instead of FTP if that makes a difference.

  4. #4
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    4,610

    Default

    It's probably due to newline differences.

    Windows text files mark newline with two characters, carriage return + line feed. Unix/Linux text files mark newline with a single character, line feed. This results in a size difference.

    If you turn on rules-based comparison it will ignore the newline difference in the Folder Compare. To turn it on, click the Rules toolbar button. Check Compare Contents. Then select Rules-based comparison.

    To prevent newline from changing when copying between Windows and Linux systems using SFTP (also FTP), open Tools > Profiles. Select the profile of your server or the default profile. Go to the Transfer tab. Set Transfer type to Binary, then Save. The default setting is Auto, which converts newline style using ASCII transfer mode for text file types (.php, .html, etc) and Binary mode (no conversion) for non-text file types (.png, .jpg, etc). Web content usually works fine if the newline style doesn't match the operating system type, but system configuration files usually don't work if newline type is mismatched.

    For more information, see the Wikipedia article on Newline:
    https://en.wikipedia.org/wiki/Newline
    Last edited by Chris; 22-May-2018 at 09:53 AM.
    Chris K Scooter Software

  5. #5

    Default

    Quote Originally Posted by Chris View Post
    It's probably due to newline differences.

    Windows text files mark newline with two characters, carriage return + line feed. Unix/Linux text files mark newline with a single character, line feed. This results in a size difference.

    If you turn on rules-based comparison it will ignore the newline difference in the Folder Compare. To turn it on, click the Rules toolbar button. Check Compare Contents. Then select Rules-based comparison.

    To newline from changing when copying between Windows and Linux systems using SFTP (also FTP), open Tools > Profiles. Select the profile of your server or the default profile. Go to the Transfer tab. Set Transfer type to Binary, then Save. The default setting is Auto, which converts newline style using ASCII transfer mode for text file types (.php, .html, etc) and Binary mode (no conversion) for non-text file types (.png, .jpg, etc). Web content usually works fine if the newline style doesn't match the operating system type, but system configuration files usually don't work if newline type is mismatched.

    For more information, see the Wikipedia article on Newline:
    https://en.wikipedia.org/wiki/Newline
    Thank you so much! Changing the rules fixed it!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •