Results 1 to 3 of 3
  1. #1
    Join Date
    Jan 2018
    Posts
    28

    Question Grammar setting not sticking...

    I have different folders with compares of the same file type. In my case they are mainframe files.
    If I change the grammar on 1 compare, the other file compares in other folders have the same grammar change.
    Can I make the grammar unique to the folder where all compares in that folder have the same grammar ?
    I tried to add grammar rules and the checkboxes are not being exercised. Here is an example below.

    (All mainframe files in Folder 1 on Grammar checkbox)
    X Item1=1 to end of line
    Item2=1 to 71

    (All mainframe files in Folder 2 on Grammar checkbox)
    Item1=1 to end of line
    X Item2=1 to 71

    When I go back and forth between folder 1 and folder 2, the settings always change from 1 to the other.
    The grammar change is global. I tried doing the lock option but that did not work.

  2. #2
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    11,788

    Default

    File Formats are global. If you are editing a format that can only be for a specific folder, then you would need multiple formats (Each defined with a mask that matches only for the specific folder, or disabled and enabled only in that Folder Compare session).

    However, if you are only defining Unimportance, this can be done for a specific saved Folder Compare session by:
    - Double click on a file in the Folder Compare.
    - In the child Compare, go to the Session menu -> Session Settings, Importance tab, and define new Unimportant rules (above the grammar list).
    - Update the bottom dropdown from "use only for this view" to "use for all files in parent session"
    - Close the child compare, and re-save the parent Folder Compare session.
    Aaron P Scooter Software

  3. #3
    Join Date
    Jan 2018
    Posts
    28

    Lightbulb great workaround

    I found a workaround solution. I highlight the compare session and do a ‘save as’
    to another session name. After opening the new saved session (with different name),
    I enter more file names for source and target that have this same record length, grammar rules, and uimportant
    rules. The settings are copied over (cloned). It is just a few steps so I am happy. I had to think out of the box.
    I am so happy now. Doing a ‘save as’ from the session to create a cloned session does the trick.
    Thanks!



    Quote Originally Posted by Aaron View Post
    File Formats are global. If you are editing a format that can only be for a specific folder, then you would need multiple formats (Each defined with a mask that matches only for the specific folder, or disabled and enabled only in that Folder Compare session).

    However, if you are only defining Unimportance, this can be done for a specific saved Folder Compare session by:
    - Double click on a file in the Folder Compare.
    - In the child Compare, go to the Session menu -> Session Settings, Importance tab, and define new Unimportant rules (above the grammar list).
    - Update the bottom dropdown from "use only for this view" to "use for all files in parent session"
    - Close the child compare, and re-save the parent Folder Compare session.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •