Ubuntu has a bug that will sometimes cause a transparent, white, or black window on systems with Nvidia graphics cards. To workaround the issue, turn off animations in Compiz.

Ubuntu Bug #1371928: Main window content fully transparent.

sudo apt install compizconfig-settings-manager
ccsm
Go to the Effects category.
Uncheck Animations.

Workaround instructions verified on Ubuntu 16.04 LTS.