Results 1 to 3 of 3
  1. #1
    Join Date
    Apr 2006
    Location
    Norwich, UK
    Posts
    39

    Unhappy SFTP does not work with IPv6 domains

    I have a server that is running only on IPv6 and BeyondCompare (4.2.4/MacOS) refused to connect to it giving the same error: "Unable to load initial remote folder"... which is total none-sense because it doesn't even reach the phase where it would prompt for the host key.

    This had nothing to do with the configuration, as soon I put an IPv4 for the same machine it started to work.

    I tried other SCP clients using IPv6 and it worked without any problems, clearly a double issue with BC: SCP IPv6 support being broken and maybe even worse: generic errors messages that do not give any hint regarding the real issue behind.

  2. #2
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    4,728

    Default

    Thank you for reporting the issue. Beyond Compare on Unix (macOS and Linux) doesn't support IPv6 SFTP. I will add it to our bug list for a future version.

    BC on Unix (macOS and Linux) does support IPv6 for FTP and FTPS.

    The Windows version of BC supports IPv6 for FTP, FTPS, and SFTP.
    Chris K Scooter Software

  3. #3
    Join Date
    Sep 2018
    Posts
    1

    Default

    Quote Originally Posted by intersol View Post
    I have a server that is running only on IPv6 and BeyondCompare (4.2.4/MacOS) refused to connect to it giving the same error: "Unable to load initial remote folder"... which is total none-sense because it doesn't even reach the phase where it would prompt for the host key.

    This had nothing to do with the configuration, as soon I put an IPv4 for the same machine it started to work.

    I tried other SCP clients using IPv6 and it worked without any problems, clearly a double issue with BC: SCP IPv6 support being broken and maybe even worse: generic errors messages that do not give any hint regarding the real issue behind.
    Hello,

    From my XP clients I pinged sftp/domain.com and it replied. When I ping the same machine from my windows 8 clients, it fails to resolve the IP. Should I check in my network centre what profile it thinks my clients are in. Should it say domain?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •