Results 1 to 3 of 3
  1. #1
    Join Date
    Mar 2018
    Posts
    2

    Default File type erroneously detected as archive file

    SELinux uses *.te files as the rules files and these are normal text files. BC, however, thinks they are terse executables and won't compare them unless I do it with the RMB menu. This is a workable solution in normal cases but when I use git difftool I simply can't use BC with these files at all.

    I can't figure out a way to change the behaviour of BC in this case. I have never seen a terse executable (at least I can't remember) so I'm perfectly happy to remove it from the archive file types but is this possible?

  2. #2
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    11,953

    Default

    Hello,

    Definitely possible and no problem; let's help get you the details. Navigate to the Tools menu -> Options dialog (or Beyond Compare menu -> Preferences if on a Mac), and go to the "Archive Types" tab. Scroll down the list to Terse Executable and remove the *.te mask from the definition. Then fully Quit and restart the BC4 application and they'll no longer be considered an archive type.
    Aaron P Scooter Software

  3. #3
    Join Date
    Mar 2018
    Posts
    2

    Default

    Ah, thanks. I didn't realise I can edit the mask. I just tried to find some button to remove the whole archive type.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •