Results 1 to 3 of 3
  1. #1
    Join Date
    May 2010

    Default load text compare session

    Beyond Compare Version: Version 4.2.3 (build 22587) - 64-bit

    1) Create a file BC_Script.txt with below line and save it to c:\temp
    text-report layout:Summary options:ignore-unimportant output-to:"%3" "%1" "%2"

    2) Create a file BatchScript.bat with below two lines and save it to c:\temp
    "" "@C:\temp\BC_Script.txt" %1 %2 "C:\temp\tmpResult.txt" /silent
    type "C:\temp\tmpResult.txt" >> "C:\temp\CombinedResult.txt"

    3) Type below commands
    @BatchScript.bat "C:\temp\File1.pdf" "C:\temp\File2.pdf" and found 1 difference A-123456

    Now, using beyond compare GUI, I saved a text compare session called ignoreText with A-\d{6}.

    How do I call ignoreText session that will ignore the difference A-123456?

  2. #2
    Join Date
    Oct 2007
    Madison, WI


    It isn't possible to load a saved Text Compare session in a script. Only Folder Compare sessions can be loaded in scripts.

    As a workaround, you can edit the importance settings for the default Text Compare session.

    Open Tools > File Formats and edit the file format that matches your files.
    Add a grammar element that matches on "A-\d{6}".
    In the Home view, in the Sessions list, select New > Text Compare.
    Click Edit Defaults.
    In the Importance tab, uncheck the grammar element that matches on "A-\d{6}", then Save.

    When you run your text-report script, it will use the default Text Compare session settings.
    Chris K Scooter Software

  3. #3
    Join Date
    May 2010


    Thank you Chris. Your solution worked.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts