Results 1 to 7 of 7

Thread: Mouse Invert

  1. #1
    Join Date
    Nov 2017
    Posts
    3

    Default Mouse Invert

    Hi there,

    I recently upgraded to BC4 and my mouse wheel is inverted. When I scroll up, the text goes down. When I scroll down, the text goes up. This is the opposite of how it works for windows explorer!
    Is there some way to change this?


    Thanks!

  2. #2
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    4,669

    Default

    Beyond Compare doesn't have a mouse wheel configuration setting, it should just follow Windows.

    What version of Windows are you using?

    What version of BC4 are you using? Open Help > About Beyond Compare to display your version.

    What mouse are you using (Logitech M510, Microsoft Optical Mouse 500, etc)?

    Do you have any mouse enhancement software from the manufacturer installed (Microsoft Mouse and Keyboard Center, Logitech SetPoint, etc)?
    Chris K Scooter Software

  3. #3
    Join Date
    Nov 2017
    Posts
    3

    Default

    Hi Chris,

    Sorry for the late reply:

    Windows 10
    1511 OS build 10586.1232

    Version 4.2.3 (build 22587)
    Beyond compare 4
    64 bit edition

    logitech m-u0007
    I have also tried a standard microsoft mouse and experienced the same problem.

    No I should have have any mouse enhancement software.

    Beyond Compare 3 works fine.



    Quote Originally Posted by Chris View Post
    Beyond Compare doesn't have a mouse wheel configuration setting, it should just follow Windows.

    What version of Windows are you using?

    What version of BC4 are you using? Open Help > About Beyond Compare to display your version.

    What mouse are you using (Logitech M510, Microsoft Optical Mouse 500, etc)?

    Do you have any mouse enhancement software from the manufacturer installed (Microsoft Mouse and Keyboard Center, Logitech SetPoint, etc)?

  4. #4
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    11,782

    Default

    Hello,

    Thanks for that info. I'm on Windows 10 with a Logitech mouse as well, but we haven't seen this behavior in office or had other reports come in yet. Was your upgrade from an earlier version of BC4 that worked, or was it from BC3 and BC4.2.3 is the only version you've had a chance to use?

    Under your Control Panel, in your Mouse settings, is anything here enabled that might explain this behavior? Are you on a laptop that also has a trackpad, and what options does it have enabled?

    Do you have Logitech Setpoint installed? In the SmartShift tab is Application specific wheel settings enabled and in BC4, BC3, or Explorer in this list? For speed and acceleration, is it set to SetPoint implementation -> Retain OS Settings? In the Tools tab (upper right) what is your curretn Control Center version and Driver version?
    Aaron P Scooter Software

  5. #5
    Join Date
    Nov 2017
    Posts
    3

    Default

    Hi Aaron,

    Beyond Compare 3 works for the mouse correctly.
    I installed BeyondCompare 4.2.3 after installing Beyond Compare 3 (which is why I considered it an "upgrade") and
    4.2.3 has always had this behavior.
    I have not tried any other versions of BeyondCompare 4

    I believe you have helped me identify the root cause:
    In windows under the mouse setting there is an option that says "Roll the mouse wheel to scroll"
    There are two options:

    *Multiple lines at a time (works as expected)
    *One screen at a time (scrolls in the opposite direction and also doesn't scroll one screen at a time)

    I have verified this on two separate windows 10 machines (my 2nd machine has a Microsoft mouse).

    What should we do from here?

    I'll answer the rest of your questions for completeness sake:
    *I'm on a desktop
    *I do not have setpoint installed or any manufacturer's drivers.

    Quote Originally Posted by Aaron View Post
    Hello,

    Thanks for that info. I'm on Windows 10 with a Logitech mouse as well, but we haven't seen this behavior in office or had other reports come in yet. Was your upgrade from an earlier version of BC4 that worked, or was it from BC3 and BC4.2.3 is the only version you've had a chance to use?

    Under your Control Panel, in your Mouse settings, is anything here enabled that might explain this behavior? Are you on a laptop that also has a trackpad, and what options does it have enabled?

    Do you have Logitech Setpoint installed? In the SmartShift tab is Application specific wheel settings enabled and in BC4, BC3, or Explorer in this list? For speed and acceleration, is it set to SetPoint implementation -> Retain OS Settings? In the Tools tab (upper right) what is your curretn Control Center version and Driver version?

  6. #6
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    11,782

    Default

    Thanks! That option was key, and I've reproduced the behavior you are seeing. I'll open a tracker entry to investigate the issue.
    Aaron P Scooter Software

  7. #7
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    4,669

    Default

    Beyond Compare 4.2.4 is now available, it fixes the mouse wheel scrolling bug.
    Chris K Scooter Software

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •