Results 1 to 7 of 7
  1. #1
    Join Date
    Oct 2017
    Posts
    4

    Default BC4 opens 3 way merge CLI arguments as 2 way CSV diff

    When I try to 3 way merge CSV files, they are opened in the standard 2 way diff window, which doesn't let me merge, or make changes to the merge result file. Then, if I switch to text-merge, I'm still in diff mode.

    Is there a way to disable CSV merge by default, or something along those lines?

    Thanks.

  2. #2
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    11,899

    Default

    Hello,

    Yes, you can add /fv="Text Merge" as a command line argument to force that view.

    Or in the Tools menu -> File Formats dialog, add an additional format New (+) Text format, and assign it a file mask of *.csv. The topmost file format associated with *.csv picks which viewer type is used by default, so .csv would then open in the Text Compare and Text Merge session types.
    Aaron P Scooter Software

  3. #3
    Join Date
    Oct 2017
    Posts
    4

    Default

    Fantastic, thanks.

    The first option sounds perfect, since the CSV diff view is generally pretty great, when needed.

    Now... who knows when I'll actually need to merge CSV again to test this.

  4. #4
    Join Date
    Oct 2017
    Posts
    4

    Default

    Well, for some reason adding /fv="Text Merge" is causing even normal text files to open in text compare mode. I'm not sure if there's something wrong with the way Intellij is running the command or what. Adding a backslash to the quotes didn't help.

  5. #5
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    11,899

    Default

    Hello,

    If you go to the Help menu -> About, do you have BC4 Standard or Pro edition? Pro is needed for Text Merging. You can revert to trial mode for testing if you are already registered for Std, here:
    http://www.scootersoftware.com/suppo...?zz=kb_evalpro

    And if you need to purchase an upgrade, here:
    http://www.scootersoftware.com/shop....=upgradepolicy
    Aaron P Scooter Software

  6. #6
    Join Date
    Oct 2017
    Posts
    4

    Default

    I definitely have the Pro edition. If I don't include /fv="Text Merge", text files load into the merge mode just fine, but the CSV didn't. With /fv="Text Merge" text files load into "Text Compare" mode. If I try from the command line, Text Merge works fine. This leads me to believe it's a problem with the way Intellij is running the commend with the quotes.
    Last edited by Parker; 06-Oct-2017 at 01:03 PM.

  7. #7
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    11,899

    Default

    Ahh, yes, if it works from the command line, then it's working. I'd suggest creating a .bat file for intelij to call (which doesn't include the extra), then within the .bat make the full call with the /fv option.
    Aaron P Scooter Software

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •