Version 4.2.4 is now available, it fixes the error messages when using BC from the command line on macOS 10.13 High Sierra.