Results 1 to 4 of 4
  1. #1
    Join Date
    Jun 2018
    Posts
    2

    Default Display issues on Linux Mint 18.3

    I've just installed BeyondCompare 4.2.4 on Linux Mint 18.3. In its out of the box configuration I'm struggling with it. I've used BC before on Windows so I know it's powerful, but on Linux I'm facing multiple issues.

    Here is a screenshot of the opening view of a simple conflict.

    First issue is that the filenames of the 'mine', 'base' and 'theirs' files are all black on dark grey. Not a good start.

    I have one conflicting line shown mostly in red but also with some random green characters in there too. I'd like that conflict line to be shown all in red but I haven't found any way to adjust this. The pale green text on pale pink background is to my eyes totally unreadable.

    I understand that where a conflicting line has some minor differences it might be useful to syntax highlight the matching text, but that presupposes that you have an algorithm that detects lines with minor differences that is at least reasonably intelligent. Here we have two lines that have absolutely nothing in common whatsoever expect three random matching characters, there is nothing to be gained here by displaying this as anything other than a whole line conflict.

    After reviewing the conflict the next thing I want to do is to add the 'their' line followed by the 'mine' line to the merge output. I've read the manual, and I've used pretty much every merge tool known to man, so how difficult can this be right?

    I click the pink arrow next to the conflict in 'theirs' and that line is duely added to the merge output. This output line is pale green on pale lilac, also unreadable.

    Then I click the light blue arrow next to the conflict in 'mine' hoping it will add that to the merge output, but no, instead it replaces the entry from 'theirs' in pale green on light blue, nearly unreadable.

    I click the conflict line on 'base' to clear the merge ouput.

    Clicking the little arrows next to the merge output itself have the same effect, no way to get both 'theirs' and 'mine'.

    In between the modified files and the merge output is a section containing each line in the current selection which also has the little arrows. No combination of clicking these has the desired effect.

    In the edit menu is the option 'Take right then left'. This performs the required operation, but for some reason this command cannot be added to the toolbar. Is there really no way to perform the most common operation of taking 'their' and 'mine' changes in order from the UI other than having to go through the menu every time or memorize the hotkey?

    On the issue of the unreadable colours if I open Tools -> Options -> Colors, Fonts, select tab File Views and under Merge Colors select either 'Left change' or 'Right change' then instead of the usual 'Text color', 'Style' and 'Background' options that most other display configuration elements have, instead there are the entries 'Important background' and 'Unimportant background', which gives the impression that I can't adjust the colour of the text at all. But it's currently completely unreadable so if I can't change the colour that's a showstopping problem.
    Attached Images Attached Images

  2. #2
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    4,648

    Default

    Beyond Compare on Linux doesn't work well with dark colored themes. Dark theme support is on the todo list for a future version.

    Cinnamon is the only Linux Mint desktop environment listed on our Linux Distribution Compatibility page.

    What Linux Mint 18.3 desktop environment are you using (Cinnamon, MATE, etc)?

    If you change your system settings to use a light colored theme, does that resolve the display issues?
    Last edited by Chris; 18-Jun-2018 at 01:51 PM.
    Chris K Scooter Software

  3. #3
    Join Date
    Jun 2018
    Posts
    2

    Default

    I'm using Cinnamon. With a light coloured theme the BeyondCompare display is perfectly legible. That doesn't resolve anything though as I'm not going to reconfigure my entire desktop theme just to support one application.

    Why is the text colour for these elements not configurable when the text colour _is_ configurable for all the other elements?

    And how can I stop conflict lines from using green text highlighting to erroneously suggest that spurious matching characters constitute some kind of correspondence?

  4. #4
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    11,678

    Default

    Hello,

    For the unreadable colors, this looks like a combination of syntax coloring and the Options dialog -> Tweaks tab -> "Show syntax highlighting on difference lines". The Merge color sections you found control the background colors (as you note), but the font foreground colors are taken from the Difference status (and should match the Text Compare). So one of the other elements in the Colors/Fonts section must be defined to either be Green or use System (which is currently Green). With the Tweak enabled, it could be matching a specific grammar type. If you can post or email in your current Help menu -> Support; BCSupport.zip to support@scootersoftware.com, we could review your settings. Include a link back to this forum thread in the email.

    With a bit of troubleshooting, I think we can fix the green text.

    When clicking the gutter commands, each would override the other. The command you are looking for isn't in the gutter, but the Edit menu -> Take Right then Left (or vice versa), which also supports a customizable hotkey. Adding stacked gutter command support is something on our wishlist.
    Aaron P Scooter Software

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •