Results 1 to 2 of 2
  1. #1
    Join Date
    Sep 2017
    Posts
    1

    Default automatische Erkennung von CSV Feldern - ausschalten, nur wie?

    Da ich trotz Suchens im Forum nicht fündig geworden bin, eröffne ich deshalb einen neuen Thread (meine ersten ).

    Folgendes Problem ist aufgetreten, beim Ordnervergleich und auch beim direkten Vergleich zweier csv-Dateien wird ein Freikommentarfeld, welches auch Datumsangaben enthält, automatisch als Datumsfeld erkannt und der ebenso wichtige Text wird nicht mehr angezeigt und nicht verglichen (Konfiguration: Windows 7 Enterprise, Service Pack 1 und Beyond Compare 4, 64 bit, Version 4.1.3 (Build 20814)).
    Abhilfe schafft bislang nur ein manuelles Umstellen der entsprechenden Spalte von "Erkannt (Datumsspalte)" auf "Textspalte", entweder im Vergleichsfenster oder auch in der Sitzungskonfiguration. Beides sehr unschön und bei mehreren hundert Spalten, die potentiell betroffen sein können, nicht unbedingt ein praktischer Weg.

    Gibt es einen gangbaren Weg, Beyond Compare zu zwingen alle Felder in csv Dateien als Textfelder zu behandeln? - Ohne dabei jedes Feld selbst "anfassen" zu müssen?

    Gibt es einen praktikablen work-around für dieses Problem?

    Vielen Dank im Voraus an alle, die mir hier Input geben können.

  2. #2
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    11,676

    Default

    Hello,

    On the Home screen of BC4, expand the New folder in the saved Sessions list, and select the default Table Compare. Click the Edit defaults button here to view the Table Compare default session settings, select the Columns tab, and click Edit default.

    Here change Type: Detected to Type:Text, then Ok/Save.

    This will apply to new Table Compare sessions, not previously saved sessions. How does this work for any new Table Compare for you?

    ================

    Hallo,

    klapp auf der Startansicht von BC4 in der Sitzungenbaumstruktur bitte den Ordner "Neu" auf, und wähle dann "Tabellenvergleich" aus. Auf der Karteireiterlasche "Spalten" klicke unten den Button "Standard bearbeiten..." an.

    In dem erscheinenden Dialog kannst Du unter "Typ" die Einstellung von "Erkannt" auf "Text" stellen. Dann klickst Du "OK" und anschließend "Speichern".

    Diese Einstellung gilt nun für neue Tabellenvergleich-Sitzungen, nicht jedoch für Deine bereits zuvor gespeicherten Sitzungen. Ist diese Lösung für Deine neuen Tabellenvergleiche nützlich?
    Last edited by Gunnar; 09-Sep-2017 at 05:28 AM. Reason: ENG->GER translation
    Aaron P Scooter Software

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •