Page 3 of 3 FirstFirst 123
Results 21 to 29 of 29
  1. #21
    Join Date
    Jul 2010
    Posts
    13

    Default

    Ok thanks. Yes I can still use BC - it's just a bit of clutter on ther console is all.

  2. #22
    Join Date
    May 2008
    Posts
    10

    Default

    I'd just like to throw in that I'm seeing this constantly and it's driving me nuts

    Code:
    /BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.1.1/Common/ChunkCompression.cpp:50: Error: unsupported compressor 8
    /BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.1.1/Libraries/CompressData/CompressData.c:353: Error: Unknown compression scheme encountered for file '/System/Library/CoreServices/CoreTypes.bundle/Contents/Resources/Exceptions.plist'
    /BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.1.1/Common/ChunkCompression.cpp:50: Error: unsupported compressor 8
    /BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.1.1/Libraries/CompressData/CompressData.c:353: Error: Unknown compression scheme encountered for file '/System/Library/CoreServices/CoreTypes.bundle/Contents/Library/AppExceptions.bundle/Exceptions.plist'

  3. #23
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    4,669

    Default

    Thanks, it's still on our bug list for an upcoming version.
    Chris K Scooter Software

  4. #24
    Join Date
    Sep 2008
    Posts
    5

    Default

    Quote Originally Posted by Chris View Post
    Thanks, it's still on our bug list for an upcoming version.
    Any progress? Still having this.

  5. #25
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    11,787

    Default

    Yes, we are working on a fix for this in the next release. We don't have an announced release date, but we're currently working on testing.
    Aaron P Scooter Software

  6. #26
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    4,669

    Default

    Version 4.2.4 is now available, it fixes the error messages when using BC from the command line on macOS 10.13 High Sierra.
    Chris K Scooter Software

  7. #27
    Join Date
    Mar 2018
    Posts
    1

    Default

    May I ask what the side effects were for this error? I can run diffs locally from my context menu but it seems my attempts at the command line all fall short on macOS High Sierra 10.13.4. I too get the above BuildRoot console messages with a different AppleFSCompression version number. The Beyond Compare GUI launches, but it never displays the folders I indicated in my arguments, it launches as if I just double clicked the Beyond Compare.app icon in Applications, just to the main home page.

    Is there any workaround for using bcomp instead of bcompare? Issuing bcomp commands seems to get my arguments recognized but I can't figure out the syntax and always bring up some kind of 3 way merge view.

  8. #28
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    11,787

    Default

    Hello,

    This was just the message text, with no other side effects for 10.13.3. We have not finished testing the latest 10.13.4beta.
    Aaron P Scooter Software

  9. #29
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    11,787

    Default

    To troubleshoot the Merge launching, can you include the code/text you are using to execute the comparison from the command line?
    Aaron P Scooter Software

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •