Results 1 to 2 of 2
  1. #1
    Join Date
    Jan 2017

    Default Trailing Zeros are truncated for CSV files while comparison

    Hi Team,

    We have two files csv files , in the files we have few decimal numbers as below:

    File1--- > File2
    172629.28 --> 172629.28000

    after doing data compare, it should ideally show mismatch,but it truncates the zeros for second file and shows data is matching.

    172629.28 --> 172629.28 [Data match]

    We are using 3.3.13 version for Beyond Compare.

  2. #2
    Join Date
    Oct 2007
    Madison, WI



    If a column in the Data Compare detects as Numeric, then the number value will be used and determined equal. If you would like to compare the text of the column, you can right click any column header and switch to Text Column instead of the detected Numeric column.

    This can be done per column, per session, or as an overall default for all future Data Compare sessions. To update defeaults, go to the Session Settings dialog, and in the Columns tab, Update Defaults or a specific column, set to Text, then switch from "use for this view only" to "also update session defaults."
    Aaron P Scooter Software

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts