Results 1 to 5 of 5
  1. #1
    Join Date
    Mar 2011
    Posts
    5

    Default Question marks (unknown characters) in file sizes

    Question marks (unknown characters) in file sizes: see the screen-shots attached to the post!
    Attached Images Attached Images

  2. #2
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    11,788

    Default

    Hello,

    In your file Explorer, what character is shown/used for that delimiter?

    What are your current Regional Settings? And which Linux OS are you currently running?
    Aaron P Scooter Software

  3. #3
    Join Date
    Mar 2011
    Posts
    5

    Default

    Code:
    [19:28:56] janis@janis-desktop /etc $ cat /etc/default/locale
    LANG="lv_LV.UTF-8"
    LANGUAGE="lv_LV:lv"
    LC_NUMERIC="lv_LV.UTF-8"
    LC_TIME="lv_LV.UTF-8"
    LC_MONETARY="lv_LV.UTF-8"
    LC_PAPER="lv_LV.UTF-8"
    LC_IDENTIFICATION="lv_LV.UTF-8"
    LC_NAME="lv_LV.UTF-8"
    LC_ADDRESS="lv_LV.UTF-8"
    LC_TELEPHONE="lv_LV.UTF-8"
    LC_MEASUREMENT="lv_LV.UTF-8"
    [19:29:02] janis@janis-desktop /etc $ cat lsb-release 
    DISTRIB_ID=LinuxMint
    DISTRIB_RELEASE=17
    DISTRIB_CODENAME=qiana
    DISTRIB_DESCRIPTION="Linux Mint 17 Qiana"
    It's hard to find a separator example, as the file explorer displays the size in KB, MB etc, so most (if not all?) sizes do not go above three digits. But if I view a file's properties, it says, for example, "Size: 106,7 KiB (109*236 bytes)".

    (Update) Hmm... That's odd. I do not see the asterisk there. Neither in the explorer, nor here in the editor when I copied the string "106,7 KiB (109*236 bytes)". But it appeared upon submitting the post only.

    (Update 2) OK, it is non-breaking space: https://unicode-table.com/en/00A0/ (bytes C2A0).
    Last edited by Jānis; 08-Mar-2017 at 10:46 AM.
    Currently Beyond Compare 4.2 beta installed, Linux Mint 17 64-bit.

  4. #4
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    11,788

    Default

    Thanks for that information. I'll open a tracker entry to investigate. This seems to be a specific issue with Linux Mint and setting the Region to Latvia
    Aaron P Scooter Software

  5. #5
    Join Date
    Mar 2017
    Posts
    1

    Default

    I see the same on Ubuntu 16.04 LTS, with Norwegian settings.
    The workaround is to run the following command before running bcompare: export LC_NUMERIC=en_US.UTF-8

    Quote Originally Posted by Aaron View Post
    Thanks for that information. I'll open a tracker entry to investigate. This seems to be a specific issue with Linux Mint and setting the Region to Latvia

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •