Results 1 to 2 of 2
  1. #1
    Join Date
    Jan 2017
    Posts
    1

    Question SFTP (SSH2) doesn't support ed25519?

    I have been using an ecdsa key pair to authenticate my SSH connections from my desktop to my local servers. I was able to SSH into a local server as root via a terminal without any password challenge.

    I set up SFTP(SSH2) 'root' user profiles for each of my servers in Beyond Compare (specifying the SSH private key file and a blank password), and that worked great.

    Recently I upgraded to a ed25519 key pair, and while I can still SSH via terminal into those same accounts, Beyond Compare no longer connects.

    Even though the password field is blank and the correct SSH private key file is specified in the profile, I still get an 'Invalid Login' dialog, and the following in the log window:

    01/29/2017 12:28:33 PM Connecting to matrix
    01/29/2017 12:28:33 PM Server key [DSS 1024 xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx]
    01/29/2017 12:28:33 PM No more authentication methods available
    01/29/2017 12:28:33 PM Connection closed.
    01/29/2017 12:28:33 PM Connection failed: Connection lost (error code is 115)
    01/29/2017 12:28:36 PM Unable to load sftp://root@matrix/: Connection lost (error code is 115)

    Is this due to a lack of support for ed25519, and if so, is there an update coming that will address this?

    Thanks!

    --- ADDITIONAL INFO: ---

    Beyond Compare 4 64-bit Edition v4.1.9 build 21719 on Debian Jessie

    I have OpenSSH 7.4 installed, and I'm running ssh-agent with my X-session. I was using a passphrase along with the ed25519 key initially, but I eventually removed it from the key, thinking that was what was causing the issue with BeyondCompare. I still have no ability to connect with the ed25519 key, even without a passphrase, so ssh-agent is probably not relevant here.

  2. #2
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    11,384

    Default

    Hello,

    Thanks. We can confirm that ed25519 keys aren't supported by our current library. If there are any other keys set up in ssh-agent or the Profile settings, BC4 will attempt to use them (and prompt for Passphrase if needed), and if none of them work we'll then prompt for Password if that authentication method is available.

    Enhancing our key support is something on our radar, but would require the library to update its support or finding another solution.
    Aaron P Scooter Software

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •