Results 1 to 2 of 2
  1. #1
    Join Date
    Dec 2016
    Posts
    1

    Default Filtering out files in Folder compare with unimportant text

    Hi.
    When comparing 2 folders with many files in each, I'd like it to know how to have it ignore (filter out) files that contain 'unimportant text', providing that's all they would have different.

    I've added the text in the Importance tab and checked View|Ignore Unimportant Differences.
    That only works after i've dblclicked on a file to open their contents and then closed it and then pressed F5....only then will they be removed from the display.

    Looking at the attachments...
    Starting out it looks like attachemnt bc1.png
    Opening the dbo.appversion.table.sql files ...see bc2.png. You can see the line it should ignore beginning with USE.
    Closing that file compare tab you get...see bc3.png.
    Now, at this point, I press F5 (not ctrlF5) to refresh the view, the file does disappear from the results Folder Compare view.

    How can it get it to do this automatically ? I just want the results of Folder Compare to show files except where the only difference is if they have whatever I've put in the Unimportant Text section.

    Any ideas? Am I missing a setting or another approach?

    Thanks in adv.
    Attached Images Attached Images

  2. #2
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    11,788

    Default

    Hello,

    The Folder Compare's Session menu -> Session Settings, Rules-based should be enabled. Then in the toolbar or View menu -> Only Compare File, a mode which will remove any 'empty' folder that is either actually empty or empty due to all items filtered out. The toolbar/View menu -> Ignore Unimportant Differences toggle can also be set to treat files with only unimportant differences as equal.

    This also requires the default Important setting should have that grammar item unchecked. To do this, open one file with the grammar, go to the Importance tab in Session Settings, uncheck your grammar, and before clicking ok update the dropdown from "Use only for this view" to "Also update session defaults", then apply. The grammar should, by default, be unimportant without needing to uncheck it each time you open the files.

    This KB article may also help:
    http://www.scootersoftware.com/suppo...ferentthensame
    Aaron P Scooter Software

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •