Results 1 to 9 of 9
  1. #1
    Join Date
    Jun 2005
    Location
    Stockholm, Sweden
    Posts
    192

    Default Filter with multiple file conditions

    Tried searching, but couldn't find what I was looking for. This is obviously an end-user error, but I can't figure out what I'm doing wrong.

    Doing a folder compare, and only want to see files that start with d7941* or paco*.
    Click on the left filter icon (without red diagonal) and enter d7941*.*;paco*.* in the include files control and click OK.
    With the red diagonal icon not selected, I don't see ANY files.
    With it enabled, I see all (?) the files (for example, MODULDRV is shown as one of the files).

    What am I doing wrong ?

  2. #2
    Join Date
    Oct 2007
    Location
    ITALY
    Posts
    209

    Default

    When You click on the left filter icon, You must enter patterns of different lines.
    d7941*.*
    paco*.*

    Regards

    Rodolfo Giovanninetti

  3. #3
    Join Date
    Jun 2005
    Location
    Stockholm, Sweden
    Posts
    192

    Default

    Thanks Rodolfo - that did the trick.

    Having said that, the online help was confusing to say the least. Under file masks it says

    Example: -*.dcu;-*.ddp would exclude files with extensions dcu, or ddp.
    so my attempts seemed logical to me

  4. #4
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    11,619

    Default

    Hello,

    The Filters toolbar in the main view will use ; separators. The Session Settings, Filters tab uses new lines for each filter. Editing either area will update the other with the correct syntax.
    Aaron P Scooter Software

  5. #5
    Join Date
    Jun 2005
    Location
    Stockholm, Sweden
    Posts
    192

    Default

    Thanks Aaron. Form a user point of view, that doesn't make much sense (my opinion).

    If I enter *.cbl and *.docx on 2 lines using the filter toolbar, when I press OK, to return, it gets "translated" to *.doc*;*.bak in the filter control (if that's the right expression) and the 2 file variations are shown.
    However, if I enter *.doc*;*.bak on ONE line using the filter toolbar, it gets "translated" to *.doc*[;]*.bak (note the brackets) and my filter shows no files.

    I now understand that multiple lines is how I HAVE to specify the syntax, and I'm sure you guys designed it to work this way (deliberately), but I'm not sure I can see the logic there.

  6. #6
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    11,619

    Default

    Hello,

    To clarify: the Filter Toolbar is the item in the main interface that is a single line high. The Name Filters Tab in the Session Settings pop-up dialog contains text boxes which allow multiple lines of entry.

    Entering *.doc*;*.bak on the toolbar should translate to the Name Filters tab as:
    *.doc*
    *.bak

    If you are seeing different behavior, please send in your BCSupport.zip from the Help menu -> Support; Export, to support@scootersoftware.com along with a link back to this forum thread for our reference. Including a saved session, or a copy paste of your inserted text in the body of the email would help with our testing to try and reproduce the issue.
    Aaron P Scooter Software

  7. #7
    Join Date
    Jun 2005
    Location
    Stockholm, Sweden
    Posts
    192

    Default

    It's been a while, but things have calmed down now. Have sent the zip file to you (just retested with the latest updates to confirm the behavior)

  8. #8
    Join Date
    Jun 2005
    Location
    Stockholm, Sweden
    Posts
    192

    Default

    I received a reply from Aaron offline, and to quote him
    ; is a valid filename character, although an uncommon one. When working with our Session Settings dialog, the list allows DOS masking but also the literal ;.
    So entering ; here is asking for that character specifically in the file name you are trying to find
    D÷÷÷h, of course it 's a valid character (and thank you for pointing that out Aaron).

    As always, when you have the reason for why something acts "strangely", then that "strangeness" is perfectly valid and thought out.

    Thanks again.

  9. #9
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    11,619

    Default

    True, the quick summary is that the Session Settings filter syntax is a little simplified and will convert to the Filter toolbar/Scripting syntax (or vice versa) as needed. [;] in the filter toolbar will match the ; character, otherwise ; is the delimiter here. The Session Settings dialog uses new lines to separate items, so ; can be used literally without [].
    Aaron P Scooter Software

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •