Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19
  1. #11
    Join Date
    Apr 2015
    Location
    So.Cal.
    Posts
    85

    Default

    Ok, I sent you an email.

    I suppose the problem can better be summarized as: loading the remote file never completes if there are diff's at the end of either file.

  2. #12
    Join Date
    Apr 2015
    Location
    So.Cal.
    Posts
    85

    Default

    Quote Originally Posted by Aaron View Post
    ... but your toolbar Status bar has been disabled...
    How would I enable this...?

  3. #13
    Join Date
    Apr 2015
    Location
    So.Cal.
    Posts
    85

    Default

    Thanks.

  4. #14
    Join Date
    Apr 2015
    Location
    So.Cal.
    Posts
    85

    Default

    You can induce this problem as follows:
    1. compare your left and right directories, pick a file on the left that currently has no diffs;
    2. using an external editor, edit the left file, add a few lines after the last line (i.e. at the end of file), save file;
    3. recompare the left/right files, goto the difference (at the end)...
    you will see the load progress bar go forever, you will see missing copy arrows, and you will not be able to edit either side.
    Last edited by joecar; 15-Dec-2016 at 06:27 PM.

  5. #15
    Join Date
    Apr 2015
    Location
    So.Cal.
    Posts
    85

    Default

    I just discovered that this happens regardless of remote profiles, i.e. it happens on local files also, as you indicated above.

    And the problem does not happen if you edit one side by adding lines at the end of the file (i.e. editing from within BC), in this case it behaves correctly.
    Last edited by joecar; 15-Dec-2016 at 08:26 PM.

  6. #16
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    11,384

    Default

    Thanks for that email. It appears to be an issue with the Patience Diff algorithm (Session Settings, Alignment tab). We'll open a tracker entry to get this fixed.
    Aaron P Scooter Software

  7. #17
    Join Date
    Apr 2015
    Location
    So.Cal.
    Posts
    85

    Default

    Thanks.

  8. #18
    Join Date
    Apr 2015
    Location
    So.Cal.
    Posts
    85

    Default

    Hi There,

    With build 22587 I still see this (missing arrows when diff is at eof)...

    and, the progress bar never finishes.
    Attached Images Attached Images
    Last edited by joecar; 22-Sep-2017 at 10:45 AM.

  9. #19
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    11,384

    Default

    Thanks for the re-ping. We haven't been able to tackle this one yet, but I'll bump our entry on the subject.
    Aaron P Scooter Software

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •