Results 1 to 3 of 3
  1. #1
    Join Date
    May 2016
    Posts
    4

    Default SFTP transfer to my computer taking too long

    I am using a script to transfer 22 files from another server to mine through SFTP. In total, all 22 files added up to 1.89 GB. It took a little more than 2 hours for it to copy all the files.

    Why does it take so long? Is there anything I can add or remove or do differently that would speed up this process?

    Below is my file I use to run with the script. Words in bold italics are changed for privacy reasons.



    # Turn logging on with most details and appends the new log to file
    log verbose append:"LogFile.txt"
    criteria timestamp:2sec;IgnoreDST size

    # Load the base folders, filtering to only copy text files
    load "LeftSide" "sftp:RightSide"
    filter cutoff:<10days
    filter "*.txt"

    # Copy different files right to left, leaving orphans and newer files on the opposite side unchanged.
    option confirm:yes-to-all
    expand all
    select rt.diff rt.older rt.newer rt.orphan
    copy right->left

    folder-report layout:side-by-side options:column-size,column-version,column-timestamp output-to:"MyFile.txt"

  2. #2
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    11,366

    Default

    Hello,

    If you place the filter commands before the load, they will be in place and the load won't compare the excluded items. Does this help speed things up?

    Otherwise the load happens first (comparing everything using the timestamp/size comparison) and then the filter is placed.
    Aaron P Scooter Software

  3. #3
    Join Date
    May 2016
    Posts
    4

    Default

    Yes, this has helped! Thank you.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •