Results 1 to 4 of 4
  1. #1
    Join Date
    Jul 2013
    Posts
    13

    Default rows not in ascending order comparing 2 csv's

    Hi there,

    i compared 2 csv's and it looked like the picture in the attachment.
    Why weren't the rows in ascending order and how to change this?

    Greetings!

    Edit: It also seems that BC has some trouble of detecting which are the colums. It "thinks" that after the comma comes a new value, but actually the ";" is the marker for a new column. (I know some will say: "that's why its called comma seperated..." but this is - at least for european version - the default if you click on save as csv excel will use ";")

    How can i tell BC to use ";" as seperator?
    Attached Images Attached Images
    Last edited by ScoobyDoo; 06-Apr-2016 at 08:08 AM. Reason: new info

  2. #2
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    11,788

    Default

    Hello,

    Files that end with *.csv are Comma Separated Values. We'll detect this file format and follow the guidelines this extension would normally follow, which includes , as the separator. Our formats are configurable if you are using .csv for a different style of data. If you need to edit the format, you can do so in the Tools menu -> File Formats dialog, and select the CSV format or create a new Table format and associate it with *.csv to override the default format.

    Once created, edit the format's Type tab to match your needed settings.

    After all of the rows and columns are properly defined and displaying correctly, BC4's Table Compare sorts by the current Key column. The Key can be set per session view by right clicking any column or multiple column headers and setting them to Key, Standard, or Unimportant. The combination of multiple Key columns is what will sort and align your files. BC4 does not currently support displaying a different column sorting other than the Key.
    Aaron P Scooter Software

  3. #3
    Join Date
    Jul 2013
    Posts
    13

    Default

    Hi Aaron,

    thanks for that informative answer. I did as you said and changed the format of .csv. Under type i removed the checkbox from 'comma' and put it in 'semicolon'. Now the order is right - but BC removed the dots from the date (first column). How can i circumsvent this. Ah and i reckognized while playing with this. If i put the checkmark in 'detect' (for automatically detecting delimeters) then i get the same result. Since detect seems quite reasonable is it error-prone or why is it not default to let BC detect it?

    Thanks again!

  4. #4
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    11,788

    Default

    The main issue you are running into is you have .CSV files that are not conforming to the standards of that format. A CSV file should have "," as the delimiter, and your files are oddly configured. Our File Format is defined to match the definitions of a .csv file.

    If they were using a different extension, we would default to Detect. Or you can create a new custom File Format: new Table Format and set to Detect or ";".
    Aaron P Scooter Software

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •