Results 1 to 7 of 7
  1. #1
    Join Date
    Apr 2014
    Posts
    5

    Default Thumbnail view on diffing multiple files

    I keep encountering an issue where in BC on OS X, the thumbnail view won't load. I'm able to produce this behavior on a second tab when I diff multiple files.

    I'm using Perforce P4V and OS X Mavericks, and my general procedure to reproduce the problem is:

    - In P4V, select two or more files that differ from the committed versions.
    - In right-click context menu for the files, "Diff Against Have Revision".
    - First tab in BC, everything's fine. Second tab, the thumbnail doesn't render properly (see attachment).
    - If I toggle the view off and back on, via View -> Thumbnail, then it renders.
    Last edited by pagej97; 04-May-2015 at 04:03 PM.

  2. #2
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    11,947

    Default

    Thanks for the report. This is a bug in the current version when calling multiple file views in quick succession. We're looking into what it would take to get this fixed.
    Aaron P Scooter Software

  3. #3
    Join Date
    Sep 2005
    Location
    MA, USA
    Posts
    11

    Default

    I'm seeing this behavior with the thumbnail view in BC 4.1.1 (build 20615) on linux (Linux Mint 17.2 KDE 64-bit to be exact).

    I use Beyond Compare as my diff/merge tool for SmartGit, and this only seems to happen when Beyond Compare is already showing a diff, so the new comparision goes in a new tab. One other behavior I noticed when this happens is that normally the tab for the new comparison becomes the "active" tab, but when this happens the previous "active" tab remains active.

    Anyway I didn't realize I had the easy workaround of toggling the thumbnail view off and back on, I'd been closing the tab and re-diffing the files.

  4. #4
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    11,947

    Default

    Thanks. This is still an open issue we need to work on. We appreciate the additional scenario/test case, and I'll add these notes to our tracker on the subject.
    Aaron P Scooter Software

  5. #5
    Join Date
    Aug 2016
    Posts
    1

    Default

    Is this still an open issue? Only, I'm seeing it on Linux 64 bit build 4.1.6.21095.

    An easy work-around is simply to hit F5 to refresh the view though.

  6. #6
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    11,947

    Default

    Hello,

    Thanks for the update. It is still open, but I'll bump it a bit with your notes.
    Aaron P Scooter Software

  7. #7
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    4,758

    Default

    The thumbnail bug is fixed in Beyond Compare 4.2 beta.

    Beta page: http://www.scootersoftware.com/beta
    Chris K Scooter Software

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •