Page 1 of 2 12 LastLast
Results 1 to 10 of 15
  1. #1
    Join Date
    Apr 2015
    Location
    Fort Worth Texas
    Posts
    8

    Question Beyond Compare stopped working on Ubuntu 14.04...

    I’m not entirely sure what happened but one day BC4 was running great and the next day its like its not installed at all...
    (I am running under Virtual Box)
    I started to do all of the "sudo apt-get blah/blah". I suspect that made what ever the issue is worse.
    Following the Install instructions here is where I am at:
    bh44962@mgeppert-VirtualBox:~/Downloads$ sudo apt-get remove bcompare
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Package 'bcompare' is not installed, so not removed
    0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
    bh44962@mgeppert-VirtualBox:~/Downloads$ sudo gdebi bcompare-4.0.7.19761_i386
    bcompare-4.0.7.19761_i386(1).deb bcompare-4.0.7.19761_i386.deb
    bh44962@mgeppert-VirtualBox:~/Downloads$ sudo gdebi bcompare-4.0.7.19761_i386.deb
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Building data structures... Done
    Building data structures... Done
    This package is uninstallable
    Cannot install 'libstdc++6:i386'
    bh44962@mgeppert-VirtualBox:~/Downloads$
    Looking online for help I see all kinds of things about Ubuntu not behaving nicely with 32 bit apps running on 64 bit installs with the later releases but at the same time I see that BC4 was tested with Ubuntu 14.04...

    Help!

  2. #2
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    4,609

    Default

    Yes, I've verified that bcompare-4.0.7.19761_i386.deb installs and runs in a default install of Ubuntu 14.04 64-bit and 32-bit following the Linux Installation Instructions page from our website.

    If you're running 64-bit Ubuntu 14.04, it should support 32-bit packages out of the box, but in case this setting was broken, you can try enabling 32-bit packages using the following command:
    sudo dpkg --add-architecture i386

    Then try running:
    sudo apt-get update
    sudo gdebi bcompare-4.0.7.19761_i386.deb

    If "apt-get update" fixes the problem, it's possible the install failed because your local repository information was out of date.
    Chris K Scooter Software

  3. #3
    Join Date
    Apr 2015
    Location
    Fort Worth Texas
    Posts
    8

    Default

    I had tried that with no Joy...
    So I run it again:
    bh44962@mgeppert-VirtualBox:~/Downloads$ sudo dpkg --add-architecture i386
    bh44962@mgeppert-VirtualBox:~/Downloads$ sudo apt-get update
    Ign http://us.archive.ubuntu.com trusty InRelease
    Ign http://www.scootersoftware.com bcompare4 InRelease
    Ign http://us.archive.ubuntu.com trusty-updates InRelease
    Ign http://security.ubuntu.com trusty-security InRelease
    Ign http://us.archive.ubuntu.com trusty-backports InRelease
    Ign http://extras.ubuntu.com trusty InRelease
    Hit http://us.archive.ubuntu.com trusty Release.gpg
    Hit http://www.scootersoftware.com bcompare4 Release.gpg
    Get:1 http://security.ubuntu.com trusty-security Release.gpg [933 B]
    Get:2 http://us.archive.ubuntu.com trusty-updates Release.gpg [933 B]
    Get:3 http://extras.ubuntu.com trusty Release.gpg [72 B]
    Hit http://us.archive.ubuntu.com trusty-backports Release.gpg
    Get:4 http://security.ubuntu.com trusty-security Release [63.5 kB]
    Hit http://us.archive.ubuntu.com trusty Release
    Hit http://www.scootersoftware.com bcompare4 Release
    Hit http://extras.ubuntu.com trusty Release
    Get:5 http://us.archive.ubuntu.com trusty-updates Release [63.5 kB]
    Hit http://extras.ubuntu.com trusty/main Sources
    Get:6 http://us.archive.ubuntu.com trusty-backports Release [63.5 kB]
    Hit http://www.scootersoftware.com bcompare4/non-free amd64 Packages
    Get:7 http://security.ubuntu.com trusty-security/main Sources [78.7 kB]
    Hit http://us.archive.ubuntu.com trusty/main Sources
    Hit http://extras.ubuntu.com trusty/main amd64 Packages
    Hit http://www.scootersoftware.com bcompare4/non-free i386 Packages
    Hit http://us.archive.ubuntu.com trusty/restricted Sources
    Get:8 http://security.ubuntu.com trusty-security/restricted Sources [2,061 B]
    Hit http://us.archive.ubuntu.com trusty/universe Sources
    Hit http://extras.ubuntu.com trusty/main i386 Packages
    Hit http://us.archive.ubuntu.com trusty/multiverse Sources
    Get:9 http://security.ubuntu.com trusty-security/universe Sources [20.9 kB]
    Hit http://us.archive.ubuntu.com trusty/main amd64 Packages
    Get:10 http://security.ubuntu.com trusty-security/multiverse Sources [1,922 B]
    Get:11 http://us.archive.ubuntu.com trusty/restricted amd64 Packages [13.0 kB]
    Get:12 http://security.ubuntu.com trusty-security/main amd64 Packages [259 kB]
    Hit http://us.archive.ubuntu.com trusty/universe amd64 Packages
    Hit http://us.archive.ubuntu.com trusty/multiverse amd64 Packages
    Hit http://us.archive.ubuntu.com trusty/main i386 Packages
    Get:13 http://security.ubuntu.com trusty-security/restricted amd64 Packages [8,875 B]
    Hit http://us.archive.ubuntu.com trusty/restricted i386 Packages
    Get:14 http://security.ubuntu.com trusty-security/universe amd64 Packages [99.7 kB]
    Get:15 http://us.archive.ubuntu.com trusty/universe i386 Packages [5,866 kB]
    Ign http://extras.ubuntu.com trusty/main Translation-en_US
    Ign http://www.scootersoftware.com bcompare4/non-free Translation-en_US
    Get:16 http://security.ubuntu.com trusty-security/multiverse amd64 Packages [3,451 B]
    Ign http://extras.ubuntu.com trusty/main Translation-en
    Get:17 http://security.ubuntu.com trusty-security/main i386 Packages [248 kB]
    Ign http://www.scootersoftware.com bcompare4/non-free Translation-en
    Get:18 http://security.ubuntu.com trusty-security/restricted i386 Packages [8,846 B]
    Get:19 http://security.ubuntu.com trusty-security/universe i386 Packages [99.7 kB]
    Get:20 http://security.ubuntu.com trusty-security/multiverse i386 Packages [3,643 B]
    Hit http://security.ubuntu.com trusty-security/main Translation-en
    Hit http://security.ubuntu.com trusty-security/multiverse Translation-en
    Hit http://security.ubuntu.com trusty-security/restricted Translation-en
    Hit http://security.ubuntu.com trusty-security/universe Translation-en
    Hit http://us.archive.ubuntu.com trusty/multiverse i386 Packages
    Hit http://us.archive.ubuntu.com trusty/main Translation-en
    Hit http://us.archive.ubuntu.com trusty/multiverse Translation-en
    Hit http://us.archive.ubuntu.com trusty/restricted Translation-en
    Hit http://us.archive.ubuntu.com trusty/universe Translation-en
    Get:21 http://us.archive.ubuntu.com trusty-updates/main Sources [194 kB]
    Get:22 http://us.archive.ubuntu.com trusty-updates/restricted Sources [2,564 B]
    Get:23 http://us.archive.ubuntu.com trusty-updates/universe Sources [113 kB]
    Get:24 http://us.archive.ubuntu.com trusty-updates/multiverse Sources [4,775 B]
    Get:25 http://us.archive.ubuntu.com trusty-updates/main amd64 Packages [502 kB]
    Get:26 http://us.archive.ubuntu.com trusty-updates/restricted amd64 Packages [9,238 B]
    Get:27 http://us.archive.ubuntu.com trusty-updates/universe amd64 Packages [273 kB]
    Get:28 http://us.archive.ubuntu.com trusty-updates/multiverse amd64 Packages [11.7 kB]
    Get:29 http://us.archive.ubuntu.com trusty-updates/main i386 Packages [491 kB]
    Get:30 http://us.archive.ubuntu.com trusty-updates/restricted i386 Packages [9,256 B]
    Get:31 http://us.archive.ubuntu.com trusty-updates/universe i386 Packages [274 kB]
    Get:32 http://us.archive.ubuntu.com trusty-updates/multiverse i386 Packages [11.9 kB]
    Get:33 http://us.archive.ubuntu.com trusty-updates/main Translation-en [237 kB]
    Get:34 http://us.archive.ubuntu.com trusty-updates/multiverse Translation-en [6,076 B]
    Hit http://us.archive.ubuntu.com trusty-updates/restricted Translation-en
    Hit http://us.archive.ubuntu.com trusty-updates/universe Translation-en
    Get:35 http://us.archive.ubuntu.com trusty-backports/main Sources [5,851 B]
    Get:36 http://us.archive.ubuntu.com trusty-backports/restricted Sources [28 B]
    Get:37 http://us.archive.ubuntu.com trusty-backports/universe Sources [24.7 kB]
    Get:38 http://us.archive.ubuntu.com trusty-backports/multiverse Sources [1,898 B]
    Get:39 http://us.archive.ubuntu.com trusty-backports/main amd64 Packages [6,256 B]
    Get:40 http://us.archive.ubuntu.com trusty-backports/restricted amd64 Packages [28 B]
    Get:41 http://us.archive.ubuntu.com trusty-backports/universe amd64 Packages [28.5 kB]
    Get:42 http://us.archive.ubuntu.com trusty-backports/multiverse amd64 Packages [1,245 B]
    Get:43 http://us.archive.ubuntu.com trusty-backports/main i386 Packages [6,285 B]
    Get:44 http://us.archive.ubuntu.com trusty-backports/restricted i386 Packages [28 B]
    Get:45 http://us.archive.ubuntu.com trusty-backports/universe i386 Packages [28.5 kB]
    Get:46 http://us.archive.ubuntu.com trusty-backports/multiverse i386 Packages [1,249 B]
    Get:47 http://us.archive.ubuntu.com trusty-backports/main Translation-en [3,645 B]
    Get:48 http://us.archive.ubuntu.com trusty-backports/multiverse Translation-en [776 B]
    Get:49 http://us.archive.ubuntu.com trusty-backports/restricted Translation-en [14 B]
    Get:50 http://us.archive.ubuntu.com trusty-backports/universe Translation-en [25.3 kB]
    Ign http://us.archive.ubuntu.com trusty/main Translation-en_US
    Ign http://us.archive.ubuntu.com trusty/multiverse Translation-en_US
    Ign http://us.archive.ubuntu.com trusty/restricted Translation-en_US
    Ign http://us.archive.ubuntu.com trusty/universe Translation-en_US
    Fetched 9,180 kB in 14s (651 kB/s)
    Reading package lists... Done
    bh44962@mgeppert-VirtualBox:~/Downloads$ sudo gdebi bcompare-4.0.7.19761_i386.deb
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Building data structures... Done
    Building data structures... Done
    This package is uninstallable
    Cannot install 'libstdc++6:i386'
    bh44962@mgeppert-VirtualBox:~/Downloads$

  4. #4
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    4,609

    Default

    What happens if you just try installing the dependency with the command "sudo apt-get install libstdc++6:i386"?
    Chris K Scooter Software

  5. #5
    Join Date
    Apr 2015
    Location
    Fort Worth Texas
    Posts
    8

    Default

    I get this:
    bh44962@mgeppert-VirtualBox:~$ sudo apt-get install libstdc++6:i386
    [sudo] password for bh44962:
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    account-plugin-facebook : Depends: libaccount-plugin-generic-oauth but it is not going to be installed or
    ubuntu-system-settings-online-accounts but it is not going to be installed
    indicator-network : Depends: libstdc++6 (>= 4.2.1) but it is not going to be installed
    Depends: unity8 (>= 7.82) but it is not going to be installed
    libapt-pkg4.12 : Depends: libstdc++6 (>= 4.6) but it is not going to be installed
    libboost-iostreams1.54.0 : Depends: libstdc++6 (>= 4.2.1) but it is not going to be installed
    libboost-program-options1.54.0 : Depends: libstdc++6 (>= 4.4.0) but it is not going to be installed
    libboost-serialization1.54.0 : Depends: libstdc++6 (>= 4.6) but it is not going to be installed
    libboost-system1.54.0 : Depends: libstdc++6 (>= 4.1.1) but it is not going to be installed
    libcanberra-pulse : Depends: pulseaudio but it is not going to be installed
    libcapnp-0.4.0 : Depends: libstdc++6 (>= 4.8) but it is not going to be installed
    libcheese-gtk23 : Depends: libcheese7 (>= 3.4.0) but it is not going to be installed
    Depends: libclutter-1.0-0 (>= 1.13.2) but it is not going to be installed
    Depends: libclutter-gtk-1.0-0 (>= 0.91.8) but it is not going to be installed
    Depends: libcogl15 (>= 1.15.8) but it is not going to be installed
    libcontent-hub0 : Depends: libstdc++6 (>= 4.1.1) but it is not going to be installed
    libdee-qt5-3 : Depends: libstdc++6 (>= 4.1.1) but it is not going to be installed
    libegl1-mesa : Depends: libgbm1 (>= 7.11~1) but it is not going to be installed
    Recommends: libegl1-mesa-drivers
    libgeronimo-jpa-2.0-spec-java : Depends: aspectj but it is not going to be installed
    libgflags2 : Depends: libstdc++6 (>= 4.2.1) but it is not going to be installed
    libgoogle-glog0 : Depends: libstdc++6 (>= 4.1.1) but it is not going to be installed
    libgsettings-qt1 : Depends: libstdc++6 (>= 4.1.1) but it is not going to be installed
    libhud-client2 : Depends: libstdc++6 (>= 4.1.1) but it is not going to be installed
    Recommends: hud (= 14.04+14.04.20140604-0ubuntu1) but it is not going to be installed
    libicu52 : Depends: libstdc++6 (>= 4.4.0) but it is not going to be installed
    libjsoncpp0 : Depends: libstdc++6 (>= 4.4.0) but it is not going to be installed
    libmediascanner-2.0-0 : Depends: libstdc++6 (>= 4.4.0) but it is not going to be installed
    Recommends: mediascanner2.0 but it is not going to be installed
    libmirclient7 : Depends: libstdc++6 (>= 4.8.1) but it is not going to be installed
    libmirclientplatform-mesa : Depends: libstdc++6 (>= 4.8) but it is not going to be installed
    libmirplatform : Depends: libstdc++6 (>= 4.5) but it is not going to be installed
    libmirprotobuf0 : Depends: libstdc++6 (>= 4.4.0) but it is not going to be installed
    libmirserver18 : Depends: libstdc++6 (>= 4.8.1) but it is not going to be installed
    Depends: libmirplatformgraphics-mesa (= 0.1.8+14.04.20140411-0ubuntu1) but it is not going to be installed or
    libmirplatformgraphics-android (= 0.1.8+14.04.20140411-0ubuntu1) but it is not going to be installed
    libonline-accounts-client1 : Depends: libstdc++6 (>= 4.1.1) but it is not going to be installed
    libprocess-cpp1 : Depends: libstdc++6 (>= 4.8) but it is not going to be installed
    libprotobuf8 : Depends: libstdc++6 (>= 4.3) but it is not going to be installed
    libqdjango-db0 : Depends: libstdc++6 (>= 4.1.1) but it is not going to be installed
    libqgsttools-p1 : Depends: libstdc++6 (>= 4.1.1) but it is not going to be installed
    libqmenumodel0 : Depends: libstdc++6 (>= 4.1.1) but it is not going to be installed
    libqt5core5a : Depends: libstdc++6 (>= 4.1.1) but it is not going to be installed
    libqt5dbus5 : Depends: libstdc++6 (>= 4.1.1) but it is not going to be installed
    libqt5gui5 : Depends: libgbm1 (>= 8.1~0) but it is not going to be installed
    Depends: libstdc++6 (>= 4.1.1) but it is not going to be installed
    libqt5multimedia5 : Depends: libstdc++6 (>= 4.1.1) but it is not going to be installed
    libqt5multimedia5-plugins : Depends: libstdc++6 (>= 4.1.1) but it is not going to be installed
    libqt5multimediaquick-p5 : Depends: libstdc++6 (>= 4.1.1) but it is not going to be installed
    libqt5multimediawidgets5 : Depends: libstdc++6 (>= 4.1.1) but it is not going to be installed
    libqt5network5 : Depends: libstdc++6 (>= 4.1.1) but it is not going to be installed
    libqt5opengl5 : Depends: libstdc++6 (>= 4.1.1) but it is not going to be installed
    libqt5qml5 : Depends: libstdc++6 (>= 4.1.1) but it is not going to be installed
    libqt5quick5 : Depends: libstdc++6 (>= 4.1.1) but it is not going to be installed
    libqt5sql5 : Depends: libstdc++6 (>= 4.1.1) but it is not going to be installed
    libqt5sql5-sqlite : Depends: libstdc++6 (>= 4.1.1) but it is not going to be installed
    libqt5systeminfo5 : Depends: libstdc++6 (>= 4.1.1) but it is not going to be installed
    libqt5widgets5 : Depends: libstdc++6 (>= 4.1.1) but it is not going to be installed
    libqt5xmlpatterns5 : Depends: libstdc++6 (>= 4.1.1) but it is not going to be installed
    libsignon-qt5-1 : Depends: libstdc++6 (>= 4.1.1) but it is not going to be installed
    libsoup2.4-1 : Depends: glib-networking (>= 2.32.0) but it is not going to be installed
    libsystemsettings1 : Depends: libstdc++6 (>= 4.1.1) but it is not going to be installed
    libthumbnailer0 : Depends: libstdc++6 (>= 4.8) but it is not going to be installed
    libubuntu-download-manager-client0 : Depends: libstdc++6 (>= 4.5) but it is not going to be installed
    libubuntu-download-manager-common0 : Depends: libstdc++6 (>= 4.1.1) but it is not going to be installed
    libubuntu-download-manager-priv0 : Depends: libstdc++6 (>= 4.5) but it is not going to be installed
    libubuntu-platform-hardware-api1 : Depends: libstdc++6 (>= 4.1.1) but it is not going to be installed
    libunity-api0 : Depends: libstdc++6 (>= 4.6) but it is not going to be installed
    libunity-scopes1 : Depends: libstdc++6 (>= 4.8.1) but it is not going to be installed
    libusermetricsoutput1 : Depends: libstdc++6 (>= 4.1.1) but it is not going to be installed
    libwebkitgtk-3.0-0 : Depends: libjavascriptcoregtk-3.0-0 (= 2.4.8-1ubuntu1~ubuntu14.04.1) but it is not going to be installed
    Depends: libenchant1c2a (>= 1.6.0) but it is not going to be installed
    Depends: libharfbuzz-icu0 (>= 0.9.18) but it is not going to be installed
    Depends: libstdc++6 (>= 4.8.1) but it is not going to be installed
    Recommends: gstreamer1.0-plugins-good but it is not going to be installed
    libzmq3 : Depends: libstdc++6 (>= 4.2.1) but it is not going to be installed
    libzmqpp3 : Depends: libstdc++6 (>= 4.8) but it is not going to be installed
    qmenumodel-qml : Depends: libstdc++6 (>= 4.1.1) but it is not going to be installed
    qtdeclarative5-dee-plugin : Depends: libstdc++6 (>= 4.1.1) but it is not going to be installed
    qtdeclarative5-folderlistmodel-plugin : Depends: libstdc++6 (>= 4.1.1) but it is not going to be installed
    qtdeclarative5-gsettings1.0 : Depends: libstdc++6 (>= 4.1.1) but it is not going to be installed
    qtdeclarative5-qtmultimedia-plugin : Depends: libstdc++6 (>= 4.1.1) but it is not going to be installed
    qtdeclarative5-qtquick2-plugin : Depends: libgl1-mesa-dri
    Depends: libstdc++6 (>= 4.1.1) but it is not going to be installed
    qtdeclarative5-ubuntu-content0.1 : Depends: libstdc++6 (>= 4.1.1) but it is not going to be installed
    qtdeclarative5-unity-notifications-plugin : Depends: libstdc++6 (>= 4.1.1) but it is not going to be installed
    qtdeclarative5-xmllistmodel-plugin : Depends: libstdc++6 (>= 4.1.1) but it is not going to be installed
    system-config-printer-gnome : Depends: packagekit-system-interface
    thumbnailer-service : Depends: libstdc++6 (>= 4.4.0) but it is not going to be installed
    ubuntu-download-manager : Depends: libstdc++6 (>= 4.1.1) but it is not going to be installed
    unity-scope-scopes : Depends: libstdc++6 (>= 4.8.1) but it is not going to be installed
    usermetricsservice : Depends: libstdc++6 (>= 4.1.1) but it is not going to be installed
    E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
    bh44962@mgeppert-VirtualBox:~$

  6. #6
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    11,616

    Default

    Hello,

    libstdc is a very conventional, core package that many Linux systems either include out of the box or at least allow you to install.

    With the error message: "Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming." would point that your distribution is either corrupted or has been modified in a very deliberate, limiting way. This would need to be fixed before you could install Beyond Compare (or, quite possibly, many other software packages).

    This forum post might help remove and reset if it is a broken package:
    http://askubuntu.com/questions/12484...-caused-by-hel
    Aaron P Scooter Software

  7. #7
    Join Date
    Apr 2015
    Location
    Fort Worth Texas
    Posts
    8

    Default


    no apt.log exists, the directory is empty.

    I have un-installed the 32 bit libraries and architect and reinstalled then with the same results.

  8. #8
    Join Date
    Dec 2007
    Location
    U.S. East coast
    Posts
    302

    Default

    What's the output from:
    Code:
    sudo apt-get -f install

  9. #9
    Join Date
    Apr 2015
    Location
    Fort Worth Texas
    Posts
    8

    Default

    Thanks so much for your help and patience...

    bh44962@mgeppert-VirtualBox:~$ sudo apt-get -f install
    [sudo] password for bh44962:
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    bh44962@mgeppert-VirtualBox:~$

  10. #10
    Join Date
    Apr 2015
    Location
    Fort Worth Texas
    Posts
    8

    Default

    Hello? Anything else to try?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •