Page 3 of 3 FirstFirst 123
Results 21 to 23 of 23
  1. #21
    Join Date
    Apr 2008
    Posts
    26

    Default

    Quote Originally Posted by Craig View Post
    You need to use the "Install Command Line Tools..." command in the "Beyond Compare" menu, which will set up symbolic links in /usr/bin. Calling "bcomp" directly from the app bundle isn't supported.
    Minor correction: Beyond Compare installs symbolic links to its command line tool links in /usr/local/bin, as it should.

  2. #22
    Join Date
    Apr 2008
    Posts
    26

    Default Outdated code signing?

    Related to this discussion, I've noticed that Beyond Compare 4.0.1 and 4.0.2 were being rejected by GateKeeper as being from an unknown developer when I launched them on OS X 10.10 (I was able to get them running via the contextual menu Open, as usual for GateKeeper).

    Looking at those two versions with "spctl -a -t exec -vv /Applications/Beyond\ Compare.app/" produces this output on OS X 10.10:
    Code:
    /Applications/Beyond Compare.app/: rejected
    source=obsolete resource envelope
    origin=Developer ID Application: Scooter Software Inc.
    (For some reason I'm not getting the same behaviour with a re-extracted copy of 4.0.0: GateKeeper will let me launch it, but the same spctl command says rejected with "source=matched cdhash".)

    A further check with "codesign -dvvv /Applications/Beyond\ Compare.app" shows that Beyond Compare 4.0.0, 4.0.1 and 4.0.2 have a version 1 signature, which is not accepted by GateKeeper on OS X 10.9.5 and later. To fix, this, Beyond Compare needs to be signed on a Mac running OS X 10.9 or later, which will give it a version 2 signature.

  3. #23
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    11,366

    Default

    Thanks for the report. We just missed the window with an expired code signing, and are working on updating that.
    Aaron P Scooter Software

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •