Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14
  1. #11
    Join Date
    Jan 2012
    Posts
    4

    Default

    SFTP (SSH2) was previously working for me, now I'm getting "Folder Not Available" dialog and error 103 in the BC log. SSH from within Ubuntu terminal works no issues, before and after the problem with BC4. I haven't done any ssh-keygen, just using name+password. Also tried deleting and recreating the ftp profile, no joy.

    If I reset all BC4 settings and start fresh, would it fix this? If yes, how do I do that?

    Client:
    BC 4.0.5 build 19480 for Linux, running on Ubuntu 14.0.4 x64 LTS.

    Server:
    Raspberry Pi B+ over wired Ethernet.
    Code:
    Server ssh version info (ssh -V) : OpenSSH_6.0p1 Debian-4+deb7u2, OpenSSL 1.0.1e 11 Feb 2013
    BC4 log:
    Code:
    02/13/2015 02:26:32 AM  Username: user
    02/13/2015 02:26:32 AM  Load comparison:  <-> 
    02/13/2015 02:26:36 AM  Connecting to 192.168.1.135
    02/13/2015 02:26:36 AM  Server key [ssh-rsa 2040 be:2c:65:dd:92:06:29:ca:77:34:8b:2f:df:df:b1:23]
    02/13/2015 02:26:36 AM  Public key authorization failed.
    02/13/2015 02:26:36 AM  Public key agent authorization failed.
    02/13/2015 02:26:41 AM  Authorization successful.
    02/13/2015 02:26:42 AM  Connection failed: Failed to establish SFTP connection (error code is 103)
    02/13/2015 02:26:42 AM  Connection closed.
    02/13/2015 02:26:42 AM  Unable to load sftp://root@192.168.1.135//root: Failed to establish SFTP connection (error code is 103)
    02/13/2015 02:26:42 AM  Load comparison:  <->
    Server /var/log/auth.log:
    Code:
    Feb 13 02:21:49 rube-info sshd[2448]: Accepted password for root from 192.168.1.136 port 60601 ssh2
    Feb 13 02:21:49 rube-info sshd[2448]: pam_unix(sshd:session): session opened for user root by (uid=0)
    Feb 13 02:21:49 rube-info sshd[2448]: subsystem request for sftp by user root
    Feb 13 02:21:49 rube-info sshd[2448]: Received disconnect from 192.168.1.136: 11: Connection closed
    Feb 13 02:21:49 rube-info sshd[2448]: pam_unix(sshd:session): session closed for user root
    Last edited by embsysdev; 13-Feb-2015 at 03:35 AM.

  2. #12
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    11,949

    Default

    Thanks.

    Would it be possible to get a test account to your FTP server? If so, you can email us at support@scootersoftware.com
    Are you able to reproduce the issue without a Public/Private Key defined as part of the profile?
    Aaron P Scooter Software

  3. #13
    Join Date
    Jan 2012
    Posts
    4

    Default

    Quote Originally Posted by Aaron View Post
    Would it be possible to get a test account to your FTP server?
    Are you able to reproduce the issue without a Public/Private Key defined as part of the profile?
    The server is a Raspberry Pi, it's not connected to the public internet, just on my firewalled network, so can't give you a test account, but you can buy a Raspberry Pi for $35 and test it yourself. The issue is with user/pw only, no keys. Password and private key fields are blank in the profile.

  4. #14
    Join Date
    Jan 2012
    Posts
    4

    Default

    It was a server config issue, my bad. Resolved by editing /etc/ssh/sshd_config.
    Changed "Subsystem sftp /usr/lib/openssh/sftp-server" to "Subsystem sftp internal-sftp".

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •