Results 1 to 6 of 6
  1. #1
    Join Date
    Jan 2008
    Posts
    49

    Default Wishlist: Allow both BC4 and BC3 to be installed at the same time.

    I am a long time user of BC3, and now I am evaluating BC4.

    The problem is that BC4 is buggy in places, and some features that I am used to in BC3 don't work at all in BC4. (Remote ssh for example), others don't work as well. (3 way merge)

    I would like to be able to use BC3 in those circumstances, but when I installed BC4, it did an upgrade and removed BC3.

    Is there a way to have both versions installed, and choose which to run? I don't use context menus in filesystem windows, but I do make heavy use of the command line, and Version control integration.

  2. #2
    Join Date
    Apr 2008
    Posts
    70

    Default

    +1

    I like to contribute to software that I find so useful, bug reports being a useful contribution, but if the problem (sftp.. so broken) is getting in the way, I have to just reinstall the old package which means my contribution stops being casual.

  3. #3
    Join Date
    Dec 2007
    Location
    U.S. East coast
    Posts
    293

    Default

    In this post, Craig suggested a way of doing this, but I haven't tried it yet:
    http://www.scootersoftware.com/vbull...59&postcount=2

  4. #4
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    11,366

    Default

    SFTP should be vastly improved from last night's release. Please update and give it a try.

    Also, in which way is the 3 way Text Merge inferior or buggy? We really want to track these down and squash them if there are any issues that'd prevent you from wanting to use BC4.
    Aaron P Scooter Software

  5. #5
    Join Date
    Jan 2008
    Posts
    49

    Default

    Quote Originally Posted by Aaron View Post
    Also, in which way is the 3 way Text Merge inferior or buggy? We really want to track these down and squash them if there are any issues that'd prevent you from wanting to use BC4.
    It is hard to quantify how the 3-way merge is worse. When I was using BC3 to resolve conflicts from git rebase or merge, then it was very good at automaticaly solving the conflict. With BC4, it feels that I have to manualy resolve the conflict more often.

    As I don't have both installed at once it is hard to find specific examples. Perhaps you need to add more test cases in this area.

    Presumably you are dogfooding with BC4? have your own developers said anything?

  6. #6
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    11,366

    Default

    Hello,

    We've had a couple minor tweaks to help make things better, but sometimes those tweaks can make things worse in other cases. Do you have a set of sample files you could post or email us at support@scootersoftware.com ?

    If you email, please include a link back to this forum thread so we can link the issue.
    Aaron P Scooter Software

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •