Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18
  1. #11
    Join Date
    Mar 2013
    Posts
    70

    Default

    FWIW, I was having same problem with an earlier build, and upgrading as Aaron suggests did resolve the problem.

  2. #12
    Join Date
    Jun 2013
    Posts
    3

    Default

    Using the latest release fixed the issue for me.

  3. #13
    Join Date
    Jan 2008
    Posts
    8

    Default

    I use the latest Beta 17677 and I am wondering where the SFTP feature is. When I try to add a profile, the only choice for protocol I see ist "FTP". Can anyone point me to the right way to enable SFTP ? Thanx

  4. #14
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    11,616

    Default

    Hello Heimi,

    Have you already registered for Std edition? SFTP is a Pro specific feature:
    http://www.scootersoftware.com/shop.php?zz=kb_editions

    The trial can run in either Pro or Std mode (in the About dialog, enabling Pro features is a checkbox). If you are still running the trial, please check here and see if the feature is enabled, then fully restart the program.
    Aaron P Scooter Software

  5. #15
    Join Date
    Jan 2008
    Posts
    8

    Default

    Ok, understood. We need to buy a PRO Version for the SFTP Support.
    Unfortunately, I just upgraded my BC3 to a standard BC4 as soon as I becam aware of the Mac OS X beta. Now I have to upgrade again.
    I do not need any of the other PRO features, but SFTP support is essential for me and a really long awaited feature (I use BC since several years now). Thanx for the info Aaron.

  6. #16
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    11,616

    Default

    Hello,

    Please email into sales@scootersoftware.com and they can help sort this out.
    Aaron P Scooter Software

  7. #17
    Join Date
    Apr 2014
    Posts
    1

    Default sftp using only default user?

    I just updated to Version 4.0 beta (build 17905) and I can't connect via sftp. From the messages I get in the log window it seems to only be trying to connect via the logged in user rather the username I specified for the Profile. Here is what's in the log window (I change the DNS name and RSA hex below to avoid publishing it in the forum):

    4/16/14 10:26:26 AM Username: cafuentes
    4/16/14 10:26:26 AM Connecting to ec2-XXX-XXX-XXX-XXX.compute-1.amazonaws.com
    4/16/14 10:26:26 AM Server key [ssh-rsa 2040 fa:20:b4:11:da:31:ee:f2:f1:9f:cb:c3:32:38:1c:06]
    4/16/14 10:26:27 AM No more authentication methods available
    4/16/14 10:26:27 AM Connection failed: Connection lost (error code is 10058)
    4/16/14 10:26:27 AM Unable to load sftp://ec2-user@ec2-XXX-XXX-XXX-XXX.compute-1.amazonaws.com/: Connection lost (error code is 10058)

    I can connect via the command line no problem. In the profile properties I have:
    Host: ec2-XXX-XXX-XXX-XXX.compute-1.amazonaws.com
    Username: ec2-user
    SSH private key file: /Path/To/My/Keys/mykeyfile.pem

    Is SFTP just broken for Mac in this latest release?

  8. #18
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    11,616

    Default

    Hello,

    If you had a key previously saved, we may need to clear out the saved blank password of the profile. Go to the FTP Profiles dialog, and first check the default profile that the key is still set there. Then go to the specific profile and make sure the Save Password checkbox is unchecked, and that a username is present. Does this get it connecting for you?
    Aaron P Scooter Software

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •