Results 1 to 7 of 7
  1. #1
    Join Date
    Dec 2007
    Location
    U.S. East coast
    Posts
    303

    Default Debian vs. Debian (older 64bit distros)

    For Ubuntu 12.04, I'm assuming the file to download is "Debian", not "Debian (older 64bit distros)"?

    In case it's relevant, my CPU is 64-bit, and I'm using the 64-bit edition of Ubuntu 12.04.
    Last edited by Dave_L; 29-Jan-2014 at 09:43 AM.

  2. #2
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    11,943

    Default

    12.04 is the transitional OS that incorporates ia32-libs-multiarch (the 32bit compatibility library which necessitates this setup process change). With all updates applied, you would use the "Debian" installer.
    Aaron P Scooter Software

  3. #3
    Join Date
    Dec 2007
    Location
    U.S. East coast
    Posts
    303

    Default

    Thanks.

    I installed it with gdebi. That initially failed with an error message:

    Selecting previously unselected package bcompare:i386.
    dpkg: error processing /nobackup/BeyondCompare/4/4.0.0/bcompare-4.0.0.17451_i386.deb (--install):
    bcompare:i386 4.0.0-17451 (Multi-Arch: no) is not co-installable with bcompare:amd64 3.3.8-16340 (Multi-Arch: no) which is currently installed
    Errors were encountered while processing:
    /nobackup/BeyondCompare/4/4.0.0/bcompare-4.0.0.17451_i386.deb
    I uninstalled bcompare 3.3.8-16340 with synaptic, then gdebi installed BC4 without any problems.

    BC4 runs properly, although I only used it briefly.

    One oddity:

    Synaptic shows packages "bcompare" (version 3.3.8-16340) as not installed and "bcompare:i386" (version 4.0.0-17451) as installed. But the Installed Files tab is empty for "bcompare:i386" ("The list of installed files is only available for installed packages"). Instead, the files are listed in the Installed Files tab for "bcompare".

    Also, the command "sudo apt-get -f install" lists a bunch of i386 libraries:
    The following packages were automatically installed and are no longer required:
    libopenal1:i386 bluez-alsa:i386 libsdl-ttf2.0-0:i386 libgconf-2-4:i386 libstdc++5:i386
    ia32-libs-multiarch:i386 libgail18:i386 libldap-2.4-2:i386 libao-common libv4l-0:i386 libqt4-qt3support:i386
    libroken18-heimdal:i386 libunistring0:i386 libcupsimage2:i386 libgphoto2-port0:i386 gir1.2-ubuntuoneui-3.0
    libnss3:i386 libcaca0:i386 gtk2-engines:i386 libgudev-1.0-0:i386 libcairo-gobject2:i386 libavc1394-0:i386
    wireless-regdb ia32-libs libaio1:i386 libsane:i386 odbcinst1debian2 odbcinst1debian2:i386 libqt4-test:i386
    libqt4-designer:i386 libsdl-mixer1.2:i386 libcap2:i386 libproxy1:i386 ibus-gtk:i386 libdbus-glib-1-2:i386
    libtdb1:i386 libasn1-8-heimdal:i386 firefox-globalmenu libspeex1:i386 libxslt1.1:i386 libgomp1:i386 iw
    libcapi20-3:i386 libibus-1.0-0:i386 odbcinst libgssapi3-heimdal:i386 libcanberra-gtk-module:i386
    libcanberra0:i386 gtk2-engines-murrine:i386 libwavpack1:i386 libqt4-opengl:i386 libsoup-gnome2.4-1:i386
    libv4lconvert0:i386 gstreamer0.10-plugins-good:i386 libbabl-0.0-0 libgegl-0.0-0 libiec61883-0:i386
    libsdl-image1.2:i386 libwind0-heimdal:i386 libsdl1.2debian:i386 libxaw7:i386 libgdbm3:i386 libcurl3:i386
    libesd0:i386 libmikmod2:i386 crda libpulse-mainloop-glib0:i386 libaa1:i386 libieee1284-3:i386 libao4:i386
    libxmu6:i386 libcanberra-gtk0:i386 libvorbisfile3:i386 libxpm4:i386 libqt4-svg:i386 libusb-0.1-4:i386
    libgail-common:i386 libhcrypto4-heimdal:i386 libraw1394-11:i386 libnspr4:i386 libshout3:i386 libdv4:i386
    libhx509-5-heimdal:i386 gstreamer0.10-x:i386 libgettextpo0:i386 libgd2-xpm:i386 libheimbase1-heimdal:i386
    libsdl-net1.2:i386 libubuntuoneui-3.0-1 libxfce4util4 libgnome-keyring0:i386 libxtst6:i386
    gtk2-engines-pixbuf:i386 libtag1c2a:i386 libssl0.9.8:i386 libmpg123-0:i386 thunderbird-globalmenu
    libmad0:i386 libsasl2-2:i386 libgsoap1 gtk2-engines-oxygen:i386 xaw3dg:i386 libheimntlm0-heimdal:i386
    libpulsedsp:i386 libodbc1:i386 libexif12:i386 libqt4-scripttools:i386 librtmp0:i386 libxp6:i386
    libsasl2-modules:i386 libltdl7:i386 libkrb5-26-heimdal:i386 glib-networking:i386 libsoup2.4-1:i386
    libgphoto2-2:i386 libtag1-vanilla:i386 libaudiofile1:i386
    Use 'apt-get autoremove' to remove them.
    Are those libraries really no longer needed? Or is there some kind of package naming confusion?

  4. #4
    Join Date
    Dec 2007
    Location
    U.S. East coast
    Posts
    303

    Default

    Any idea on what's going on here?

  5. #5
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    11,943

    Default

    Hello,

    Some of those do not look like a list of our dependencies. Assuming a default install location, you can check our current dependencies with:

    export LB_LIBRARY_PATH=/usr/lib/beyondcompare
    ldd /usr/lib/beyondcompare/BCompare

    Depending on how/when it was installed, it's possible a larger i386 package was brought in to handle a subset of dependencies, but the entire package is not necessarily needed for Beyond Compare specifically.
    Aaron P Scooter Software

  6. #6
    Join Date
    Dec 2007
    Location
    U.S. East coast
    Posts
    303

    Default

    Aaron, thanks. I autoremove'd those files and don't seem to have any adverse effects.

    What about the other question?

    Synaptic shows packages "bcompare" (version 3.3.8-16340) as not installed and "bcompare:i386" (version 4.0.0-17451) as installed. But the Installed Files tab is empty for "bcompare:i386" ("The list of installed files is only available for installed packages"). Instead, the files are listed in the Installed Files tab for "bcompare".

    But if I use the command
    Code:
    dpkg --listfiles bcompare:i386
    it produces the apparently correct list of installed files.

    Maybe this is a glitch with the package manager, and nothing to do with BC, so it may not be your problem.

  7. #7
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    11,943

    Default

    Hello Dave,

    BCompare is a 32bit application on Linux. Previously, we had two different installers: a 32bit installer, and 64bit installer that contained the 32bit program and the necessary 64bit dependencies for backwards compatibility. Ubuntu 12.04 has transitioned to using ia32-libs, which is a method to handle 32bit applications on a 64bit OS, that uses the 32bit installer. This depreciated the need for us to have the 64bit installer, as both 32bit and 64bit OS's (using ia32-libs) could install the 32bit installer.

    I'm not sure exactly what package structure Synaptic is grabbing from, but it is likely treating "bcompare" as the older 64bit method/package, despite the fact it is not actually a 64bit application.

    I installed Synaptic on my test system, and found (after installing BC3, then BC4) that both were referenced as bcompare:i386. I'm not as familiar with this package manager, however, so I'm not sure which other tab or conflicting information you are seeing?

    UPDATE: Actually, after discussing with our Linux developer, the "amd64" package was also entirely 32bit - that was just the convention required for installing any 32bit package onto a 64bit machine. The package had to have "amd64" in the name. The Package Manager would then recognize that it was a 32bit application inside the package, and install the necessary 32bit backwards compatibility libraries. Newer versions of various Linux OS no longer require this naming convention (and, coincidentally, also use a different backwards compatibility library).

    This doesn't quite change the outcome/information listed in Synaptic (as, it still looks like it is detecting the two packages differently), but does help clarify the fundamental reasons for why we needed two packages to begin with when we launched BC3 Linux back in 2008.
    Last edited by Aaron; 01-Apr-2014 at 09:04 AM. Reason: UPDATE
    Aaron P Scooter Software

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •