Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14
  1. #11
    Join Date
    Jul 2011
    Posts
    23

    Default

    I'm running on Ubuntu 14.04 and when I updated to the latest BC4, it upgraded my i386 version to the x64 version which leaves an apt-get error "ia32-lib dependency". I think a better way to fix this issue is as follows:

    Remove the ia32-lib dependency and replace it with "lib32z1, lib32ncurses5, lib32bz2-1.0"

    To verify, I did the following:
    Download the x64 Debian package and then unpack the package as follows:
    > mkdir bc_temp
    > sudo dpkg-deb -x bcompare-4.0.0.17905_amd64.deb bc_temp/
    > sudo dpkg-deb --control bcompare-4.0.0.17905_amd64.deb bc_temp/DEBIAN
    Now edit the file bc_temp/DEBIAN/control
    > sudo gedit bc_temp/DEBIAN/control
    Replace the line:
    Depends: ia32-lib
    with
    Depends: lib32z1, lib32ncurses5, lib32bz2-1.0
    Save file and then:
    > dpkg -b bc_temp/ bcompare-4.0.0.17905_amd64-modified.deb
    Install this package and there should be no dependency issues.

    Regards,
    John

  2. #12
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    11,908

    Default

    Hello,

    The amd64.deb is only for older versions of Ubuntu/Debian. 14.04 should use the i386 installer, which then uses ia32 multiarch for backwards compatibility.
    Aaron P Scooter Software

  3. #13
    Join Date
    Jul 2011
    Posts
    23

    Default

    Hi Aaron,

    This I know, but when I clicked on the upgrade, BC installed the AMD64 version and created a conflict in my package manager. This was just my attempt to resolve this issue.

    Regards,
    John

  4. #14
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    11,908

    Default

    Thanks for clearing that up. Delivering the amd64 package after you initially used the i386.deb is a bug. We'll investigate this and get it fixed.
    Aaron P Scooter Software

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •