Page 1 of 2 12 LastLast
Results 1 to 10 of 17
  1. #1
    Join Date
    Feb 2008
    Location
    Lynge, Denmark
    Posts
    109

    Default BUG: Can not handle international characters in FTP

    I have tried to synchronize some files and folders with Danish letters against a FTP server. It fails. (this behavior is also seen with other mac apps).
    It does work, however, with BC3 on a Windows7 box.

    I have made a small video to illustrate the problem.

    http://www.sternberg.dk/bctest/ftp-w-int-letters.swf

  2. #2
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    2,505

    Default

    For reference, can you give us a screenshot of Internet Explorer on Windows with the View->Encoding->More submenu open? A copy of the FTP log showing the initial login and connection would help too.

    Edit: Safari has a View->Text Encoding menu that has a similar list. It would be useful to see that one too.

    This isn't a bug exactly. Your FTP server and OS X are using different character encodings for filenames, so characters like ō are stored differently and get converted to ? somewhere. Windows uses the same encoding as the server, so there's no conversion. In BC you can normally change that setting in the FTP Profiles dialog to tell it what encoding to use, but the one that you probably need (code page 865) isn't available in the dropdown because we're using a shorter list that we copied from IE. I'm curious if they have a different list in different countries.
    Last edited by ZoŽ; 28-Jun-2013 at 09:14 AM.
    ZoŽ P Scooter Software

  3. #3
    Join Date
    Feb 2008
    Location
    Lynge, Denmark
    Posts
    109

    Default

    I have tried to make the screen shot but since this is a drop Down menu Alt-PrtScr "flips" the menu back and there will not be anything interesting in the screen shot. The same happens in Jing.

    So I took a photograph instead - looks awful, but I guess it is readable (I also had to "squeeze" the jpg to get it small enough for attachment...)

  4. #4
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    2,505

    Default

    Hmm. In that case, try opening the FTP Profiles dialog from the "Beyond Compare" menu, and on the first tab look for the "Encoding" dropdown and try changing it to "Western European (ISO)". You may need to restart BC to make the change take effect.
    ZoŽ P Scooter Software

  5. #5
    Join Date
    Feb 2008
    Location
    Lynge, Denmark
    Posts
    109

    Default

    no go. Same thing happens as before.

  6. #6
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    2,505

    Default

    In that case, open the Preferences dialog and on the Advanced tab under "Log Panel", turn on "Debug messages", then connect to the site, upload one of the troublesome files, and then save the log (right click on the log panel) and send a copy to support@scootersoftware.com.
    ZoŽ P Scooter Software

  7. #7
    Join Date
    Feb 2008
    Location
    Lynge, Denmark
    Posts
    109

    Default

    sent

  8. #8
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    11,612

    Default

    Thanks. We received the log and will look into it.
    Aaron P Scooter Software

  9. #9
    Join Date
    Feb 2008
    Location
    Lynge, Denmark
    Posts
    109

    Default

    I can confirm that the problem with Danish characters is fixed in the new build (16447)

    However a new problem has occurred. The time stamp on the FTP server is off by 1 hours and 59 minutes after copying a file to the sever. If I copy from the FTP server to the local host (mac) the time stamp is set correct on the copy (i.e the same).

    A screen shot showing the upload problem is attached.

  10. #10
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    11,612

    Default

    Thanks for the report. I think I've reproduced something similar.

    In the future, would it be possible to get a separate forum thread for a new issue? This way, other users could find the thread if they are having the same issue.
    Aaron P Scooter Software

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •