Results 1 to 10 of 10
  1. #1
    Join Date
    Feb 2013
    Posts
    6

    Default Odd formatting in Text Compare Report HTML Output

    When doing a text compare HTML report between two files, I am getting odd formatting that I cannon get rid of. When I first ran the report, I had a browser window open that was very wide -- spanning 2 monitors. The report took up the available space (very wide) and was nicely formatted. Now when I produce the same report, it is always formatted for the same super-wide browser window, though I want it to fit in my one-screen, normal-sized browser window. This causes issues in a normal sized window because you have to use the side-to-side scroll bar to see the content, and in no case can you see everything at once. Yes, I have allow word wrapping checked, and it is actually wrapping the text.

    I have tried renaming the files and then re-comparing, but BC3 seems to remember these files anyway and keeps the giant spacing. Is there any way to make BC3 forget the HTML output format it seems determined to hold onto for this particular text compare?

    When I compare other files, the output is formatted as I would expect -- the right size, etc.

  2. #2
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    11,788

    Default

    The wrapping should be controlled by the Browser window, not BC3 itself. The option you found is actually a negative option, disabling it adds code to prevent word wrapping.

    If you enable Visible Whitespace in the main comparison window and the report, is there additional, actual whitespace in the file that is causing the issue?

    Would it be possible to get a copy of the report, and a full screen screenshot of what you are seeing? You can post here or email us privately at support@scootersoftware.com
    If you email us, please include a url link to this forum thread for our reference.
    Aaron P Scooter Software

  3. #3
    Join Date
    Feb 2013
    Posts
    6

    Default

    It seems to be an issue with the no good spots to wrap the text. In many of the lines I'm dealing with, there are no spaces for quite a long run except for 1 at the beginning of the line. I'll see if I can get you something and send it to the email address.

  4. #4
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    11,788

    Default

    Hello,

    If there is no whitespace, browsers generally cannot wrap that line, which will stretch the entire report. So, was this no-whitespace line a new addition that caused this problem?
    Aaron P Scooter Software

  5. #5
    Join Date
    Feb 2013
    Posts
    6

    Default

    The code often has long lines of non-white space. I hadn't noticed it before because this code is the longest I have yet hit, but far from the longest in this code base.

    Is it possible for me to create some type of template or something that would force a wrap to occur at a given location? I know I could hand edit the html output to make this occur, but that would be quite time consuming.

  6. #6
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    11,788

    Default

    Not that I know of. HTML only wraps on whitespace. The option to Enable Wrapping in HTML Reporting adds no extra code. When disabled, we then add extra code into the HTML to prevent wrapping.
    Aaron P Scooter Software

  7. #7
    Join Date
    Feb 2013
    Posts
    6

    Default Add to Wishlist

    I would like for there to be some way for me to specify a max width for my html report or maybe the ability to hard wrap at anything past a certain number of columns. Thanks.

  8. #8
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    11,788

    Default

    You could implement a hard wrap in the program using the Tools menu -> File Formats, select specific format, and in the Conversion tab you can set the characters per line limit. The default is 4096. However, BC3 compares line by line, so this will likely change the comparison results if the same text is on different lines.
    Aaron P Scooter Software

  9. #9
    Join Date
    Feb 2013
    Posts
    6

    Default Partially Solved

    Thanks for that last suggestion. While it causes some other issues for me (I don't want most of my text compares to limited to ~100 chars), it works to get me past the current bump. Thanks again.

  10. #10
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    11,788

    Default

    If you do not need it all the time, you can have a File Format with no extension, or place it at the bottom of the list. This way, one with a matching extension that is higher in the Format list is picked automatically, and you can manually select the "WrapAt60" format when it is needed.
    Aaron P Scooter Software

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •