Results 1 to 2 of 2
  1. #1
    chewy2850 Guest

    Default Align with option not available unless using text based files

    I recently came across a case where I wanted to use the align with option on a set of files that were not text based (csv and/or xlsx) and was unable to use this option. However, when I converted the files to text files it worked like a charm. Any reason why the align with/isolate (possibly other edit menu commands) are not available when comparing csv or xlsx files?

  2. #2
    Join Date
    Oct 2007
    Location
    Madison, WI
    Posts
    11,374

    Default

    By default, CSV and XLSX files open in the Data Compare session type instead of the Text Compare session type.

    The Data Compare organizes rows by Key column, which defaults to Column 1. Were your files opening in a view that looked like it had cells, rows, columns, etc, like this:
    http://scootersoftware.com/moreinfo....ot=DataCompare

    The session type is also mentioned by name in the top Title bar (same bar that has the 'X' Close button, or '_' minimize button).

    You set which column is a Key column, you can change this in the Session Settings -> Columns tab, or by right clicking the column header in the graphical interface and setting any column to Key, Standard, or Unimportant. Since multiple columns can be a Key, you may need to set a new one to be a Key, then go back and set Column 1 to be Standard or Unimportant.
    Aaron P Scooter Software

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •