Announcement

Collapse
No announcement yet.

git version 2.30.0.windows.2

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • ampa
    replied
    Update with fix: Seems that my git installation directory had smthg to do with it, I realised when I installed git I didnt have admin rights and using the dfault installation dir in the wizard ended up somewhere nested in the user directory. Unistalling and installing git with installtion dir set to program files fixed my problem. Thank for ur support

    Leave a comment:


  • Aaron
    replied
    Not specifically, but I can verify with my own install's Git Bash that it works with my simple test repository. git version 2.30.0.windows.2.

    It may be worth still emailing in your .gitconfig so I can take a look over it, with a link back to this forum thread for our reference.
    You can also try (after backing up) an uninstall and reinstall of git, to see if there were any issues with the current install, or perhaps a configuration pick in the wizard? I generally use the default settings.

    One other thing to try: add the C:\Program Files\Beyond Compare 4\ install directory to our user's PATH, so "bcomp" works from any location called? And, to verify, you do have BC4 installed to the default location (Program Files\, not Program Files (x86)\) assuming a New 64bit Install?

    Leave a comment:


  • ampa
    replied
    Thanks for the tip, actually never tried before with anything else but git bash, so gave git cmd a try. It seems that this is the problem, as I can successfully use bc from git cmd... Do you have any troubleshooting tips specifically for git bash?

    Leave a comment:


  • Aaron
    replied
    Hello,

    I'd suggest emailing in your .gitconfig to support@scootersoftware.com so we can take a look at it, if there's anything out of place or subtle syntax issue.
    Please include a link back to this forum thread for our reference in the email.

    Which command line environment are you launching the diff from?

    Leave a comment:


  • ampa
    replied
    Hi Aaron,
    Thanks for replying. So I am only using the global setting for these things.
    I verified that the global setting is used by altering the name of the exe, and the failure was as expected:

    git config --global difftool.bc.path "c:/Program Files/Beyond Compare 4/bcomp4.exe"
    git difftool master -y
    The diff tool bc is not available as 'c:/Program Files/Beyond Compare 4/bcomp4.exe'
    fatal: external diff died, stopping at xxx

    I am using git for windows, dl from https://git-scm.com/downloads
    and followed the relevant section from your Using Beyond Compare with Version Control Systems page.

    I never had a problem before, have been happily using bc with git for windows for a number of years..

    Leave a comment:


  • Aaron
    replied
    Hello,

    No, no known issues; I just updated my personal install from 2.29 to 2.30 and it seems to still be ok.

    For these issues, the first thing I recommend is updating the .gitconfig in a way that will fail in a known way, such as providing the path to bcomp.exe. I find myself sometimes editing the wrong .gitconfig for the current project or git instance, so by creating a known error, I know I'm editing the right place.

    Also, how did you install Git? Git, GitHub, and other instances can require different .gitconfig configurations.
    https://www.scootersoftware.com/support.php?zz=kb_vcs

    Leave a comment:


  • ampa
    started a topic git version 2.30.0.windows.2

    git version 2.30.0.windows.2

    Hi,

    I have been having issues using git as my git difftool/mergetool since git version 2.29
    I have tried both bc and bc3 settings to no avail.
    Is this something that is known? Do you have like a matrix of supported git versions?


    git difftool -y
    The diff tool bc is not available as 'c:/Program Files/Beyond Compare 4/bcomp.exe'
    fatal: external diff died, stopping at ...

    $ git --version
    git version 2.30.0.windows.2

Working...
X