No announcement yet.

git difftool -d gives "Folder Not Available" popup in BC4

  • Filter
  • Time
  • Show
Clear All
new posts

  • git difftool -d gives "Folder Not Available" popup in BC4

    My office is transitioning to git, and I am trying to use BC4 as my git diff & merge tool. I have configured git as described in the support pages (see config excerpt below):

    C:\Git work\4.08.X_ref>git config -l
    difftool.bc.path=C:/Program Files/Beyond Compare 4/bcomp.exe
    mergetool.bc.path=C:/Program Files/Beyond Compare 4/bcomp.exe

    When I run "git -difftool -d <commit 1> <commit 2>", a new tab opens in BC4, with "Error opening file" in both folder path boxes, and I get a "Folder Not Available" popup dialog showing a path (for example, "C:\users\<name>\AppData\Local\Temp\git-difftool.a06636\left"). This folder does not exist, although if I have the temp directory open in Windows Explorer while running "git difftool", a folder appears to be created and then destroyed almost immediately. This appears to be a timing issue of some sort -- I sometimes get a right folder in BC4, but never both a right and left.

  • #2
    Also tried this with individual files (same git command, without "-d") and get "file not found" errors; again, files appear to be created and destroyed immediately in the temp directory.


    • #3

      Which Git environment and version are you using specifically? We sometimes see different behavior if using an older Git, or a difference between Git and GitHub, for example.

      Closing immediately is usually a symptom of using "bcompare.exe" instead of "bcomp.exe" (like you have done). Bcomp.exe is designed to wait during the call, so that the temp files will stay generated. For the sake of troubleshooting, we should work first on the simplest case of file to file, and then once that is working re-investigate "-d"

      Are you using the latest Git version (Git-scm, GitHub, or something else)?, and latest BC4 (4.2.4)?
      Aaron P Scooter Software


      • #4
        Turns out to be user error. Installed the latest batch of Windows 10 updates recently, and when I opened my git command window after restarting the PC, I neglected to run it as Administrator. I apologize for wasting your time.


        • #5
          No problem. Great that you were able to figure out what the block was.
          Aaron P Scooter Software