Announcement

Collapse
No announcement yet.

When using git --dir-diff BC doesn't seem to know how to match files

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • When using git --dir-diff BC doesn't seem to know how to match files

    I've attached a screenshot. Note how I can't single-click to select both files, I have to manually select the file on the left and the file on the right in order to show the diff.

    I've configured git by using these instructions: http://www.scootersoftware.com/suppo...b_vcs#gitlinux

    The git command used is:

    Code:
    git difftool --dir-diff HEAD~1
    Attached Files

  • Aaron
    replied
    Hello,

    You can update the Session Defaults on the Home screen, in the Saved Sessions' list New folder, select Folder Compare. You can update here, or, if you already have a Folder Compare open and modified the Session Settings, the dropdown at the bottom can be changed from Only use for this View to Also update session defaults.

    This change will then be applied to all future folder comparisons, but not any already saved sessions.

    Leave a comment:


  • drey08
    replied
    Ah damn,

    I really apologize for this, it appears I was right that I mentioned this last year.

    See here: http://www.scootersoftware.com/vbull...ght=#post48060

    I bought a BC license today because I was getting really tired of Meld's half-assed OSS implementation and I knew BCompare was better. I've used BCompare on Win32 many years ago and it was always fantastic, I wanted something equivalent on Linux for work.

    Anyway, could you try to change the default setting to follow symlinks (on Linux only at least?).

    I'm pretty sure Linux users do not ever want to diff between a file and a symlink's actual contents, they want to diff between the file and the file a symlink points to.

    Leave a comment:


  • drey08
    replied
    I've realized late today that the diff it actually shows is between a file and a symlink.

    I'll try the setting Aaron suggested.

    In fact I'm pretty sure I've ran into this years ago when I tried the trial version.

    I'll try this tomorrow and report back. Cheers!

    Leave a comment:


  • Aaron
    replied
    Hello,

    You will also need to enable the Session Setting, Handling tab: Follow symbolic links.

    This can be per session or set as a global default for all future sessions. This will treat symlinks (the right side) as their target destination.

    Leave a comment:

Working...
X