Announcement

Collapse
No announcement yet.

Unable to load base folder error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Unable to load base folder error

    I've been using BC scripts for a LONG time. A script that worked fine on 10/19/2019 12:37 am failed on 10/20/2019 12:38 am (and has been failing since). The script TECHNICALLY gets rebuilt each night (I use a TABLE of folder/file pairs that I want to automate and a parent process reads the table, builds the script and runs it. This has been working perfectly for literally YEARS, but ONE folder pair started failing on the 20th. INTERACTIVELY, I can drill all the way to the lowest level folder using 3 different techniques (I:\..., \\LocalHost\..., and/or \\<machine>\...), but once I get to the lowest level folder, if I try to set it as the Base Folder, it says "Folder Not Available". Anyone have any thoughts?

    There's definitely SOMETHING fishy with that folder, but I can't pin it down. I believe I've worked around it by doing the following: Create a new folder, copy the contents from the original (failing) folder into the new, then do a couple renames ... But I sure don't want to have to do that on a regular basis!

    I'll paste a copy of the script here just so you can see there's nothing crazy in it:

    Log Verbose Append:\\Mark\Temp\BC_DropBox_Log\Pics_20191020_00 3800.TXT
    Load "\\Mark\Scans\Pics" "\\Mark\DropBox\BackUp\Pics"
    Option Confirm:Yes-To-All
    Sync Create-Empty Mirror:Left->Right
    Beep

    Thanks in advance. Mark

  • #2
    Hello,

    For the script, if you roll back to earlier examples of working script folders, do they still work?

    If you reconfigure the above script and replace one side (then the other) with c:\temp, which of the above two directories is the problem folder?

    My first hunch is if \\Mark\ has been successfully loaded/bound as a network resource before the script runs (something I wouldn't expect to have changed, but is the most common point of failure when automating against a network). For your other testing, is this done all in scripting in the same script-called environment, or graphically from the command line after logging in to Windows? Logging in can provide different results if there are any login scripts or services that are impacting the network connection, either with the \\Mark\ location, or Dropbox is that folder is dropbox controlled.
    Aaron P Scooter Software

    Comment


    • #3
      Thanks for the note Aaron. I basically RENAMED the folder (added "2" to the end), then right-click, new-folder, and re-created the original name, then copied the contents from "2" to the original. Last night it worked like a charm again. Odd is all I can say. The UNC syntax I use is in dozens of these scripts and as I said, have been working untouched for years.

      OK, I'll try to answer your questions. This is a Windows 10 machine and I AM logged in. There is a script launched by the Task Scheduler (12:30 am) which eventually results in these scripts being built and run. The offending folder was DEFINITELY the lowest level one on the "source" (left) side of the BC folder-compare. Re-creating it removed the issue ...

      Thanks again. Hopefully it was a very isolated fluke.

      Comment

      Working...
      X