Announcement

Collapse
No announcement yet.

Syncing is not deleting read only orphans

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Syncing is not deleting read only orphans

    I am executing the script below to backup a folder. It is not deleting orphans with the read only attribute set. I confirmed this by unsetting the read only attribute of one of the files and re-running the script and it deleted the file just fine. Is there an option to force deletion of read only orphans on SYNC?

    load "c:\users\Scott\AppData\Local\Microsoft\Office " "f:\roth_backup\Scott_Desktop\AppData\Local\Micros oft\Office"
    filter ""
    expand all
    sync create-empty mirror:lt->rt

  • #2
    Yes, are you running in silent mode? This would suppress the Read-Only dialog asking if you can delete the read only files. If this dialog is the cause, you can add an option at the start of script to always answer Yes.

    option confirm:yes-to-all
    filter "*.*"
    load "c:\users\Scott\AppData\Local\Microsoft\Office " "f:\roth_backup\Scott_Desktop\AppData\Local\Mi cros oft\Office"
    expand all
    sync create-empty mirror:lt->rt
    Aaron P Scooter Software

    Comment


    • #3
      That didn't quite help, but I also noticed there are more than just read only files. Let me give more details. Here is the command line I am executing:

      "C:\Program Files\Beyond Compare 4\BCompare.exe" /silent @"c:\users\Scott\Documents\_Executables\bc_Desktop _AppData_Backup_F.txt"

      Here is the FULL script in bc_Desktop_AppData_Backup_F.txt:

      #
      # Set logging to log verbose output and append to c:\users\Scott\documents\_executables\bc_backup.tx t
      #
      option confirm:yes-to-all
      log verbose append:c:\users\Scott\Documents\_executables\bc_ba ckup.txt

      load "c:\users\Scott\AppData\Local\Microsoft\Office " "f:\roth_backup\Scott_Desktop\AppData\Local\Micros oft\Office"
      filter ""
      expand all
      sync create-empty mirror:lt->rt

      Here is the output in bc_backup.txt:

      1/23/2019 8:46:37 PM >> log verbose append:c:\users\Scott\Documents\_executables\bc_ba ckup.txt
      1/23/2019 8:46:37 PM >>
      1/23/2019 8:46:37 PM >> load "c:\users\Scott\AppData\Local\Microsoft\Office " "f:\roth_backup\Scott_Desktop\AppData\Local\Micros oft\Office"
      1/23/2019 8:46:37 PM Load comparison: C:\Users\Scott\AppData\Local\Microsoft\Office <-> F:\roth_backup\Scott_Desktop\AppData\Local\Microso ft\Office
      1/23/2019 8:46:37 PM >> filter ""
      1/23/2019 8:46:37 PM >> expand all
      1/23/2019 8:46:37 PM >> sync create-empty mirror:lt->rt
      1/23/2019 8:46:37 PM Script completed in 0.05 seconds

      But, if I open a session in the UI and do a compare, I see there are many things not sync'd (see screenshot below). Click image for larger version

Name:	BeyondCompare_Sync.PNG
Views:	54
Size:	82.4 KB
ID:	79771

      Comment


      • #4
        Oops, I see my error. In UI I was looking at wrong backup folder (Scotts_Laptop) vs the directory I am backing up to (Scotts_Desktop). I just checked Scotts_Desktop and everything is perfect. If you want to delete both posts, that is fine and I can reply back that you solved my problem. Or just leave this. Thanks Aaron!!!

        Comment

        Working...
        X