Announcement

Collapse
No announcement yet.

Hide command doesn't work quite right

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • zippy99
    started a topic Hide command doesn't work quite right

    Hide command doesn't work quite right

    Either from the menu "Beyond Compare > Hide Beyond Compare" or the shortcut Command+H, Beyond Compare doesn't hide itself properly. It's just putting another application in the foreground rather than disappearing from the desktop.

  • ZoŽ
    replied
    The issue will likely be fixed when we get the 64-bit version out next year. It won't be fixed before then.

    Leave a comment:


  • Thilo Schmidt
    replied
    Today I updated BeyondCompare to the latest version, but this problem still exists. I think this bug exists since BeyondCompare runs on Macs.
    It would be a nice Christmas present after almost 5 years if this reproducible bug (thanks Scott) could finally be fixed.

    Thilo

    Leave a comment:


  • Aaron
    replied
    Thanks for this reproducible case. I'll update our tracker notes on the subject.

    Leave a comment:


  • cold1203
    replied
    Here is a scenario:
    1. open a comparison of two files
    2. in another editor, edit one of the files and save
    3. bring back BC, it will ask if you want to reload because the file has changed
    4. choose yes or no (doesn't matter)
    5. now "hide" will send it to the back of all windows, but will never truly hide until the app is restarted.



    Hope this helps
    Scott

    Leave a comment:


  • Aaron
    replied
    Hello,

    We thought the issue was resolved, but it's apparently still an issue. Could you provide screenshots with precisely the behavior you are seeing before you Hide and after your Hide if possible? Or describe in detail what you were doing before and after executing a Hide?

    Leave a comment:


  • zippy99
    replied
    I've been working round this bug for a few years now. It would be good if you could fix it once and for all.

    Is there any info we can give you that would help?

    Leave a comment:


  • cold1203
    replied
    hello, i wanted to bump this thread and let you know this is still an issue. I'm on the latest beta (Version 4.2 (build 22302)) but it's been an issue for a long time.

    'Hide' is acting more like 'send to back' than a true 'hide'.

    Leave a comment:


  • Aaron
    replied
    Thanks for the follow-up report. I'll update the tracker entry for our developers to re-investigate this.

    Leave a comment:


  • derbbre
    replied
    FTR, build 17036 still has this issue on my machine. Just in case you thought it was closed. The behavior was changed a little, though. Now the initial session window won't hide at any time (even after creating a new window), but any newly created windows will hide properly.

    Even more stranger, if I add a new tab to the non-hiding window, it will hide properly but if I remove the new tab the window will revert to not hiding. Very odd.
    Last edited by derbbre; 27-Nov-2013, 04:27 PM.

    Leave a comment:


  • Aaron
    replied
    We have a potential fix currently in development. Please keep an eye out for the next build and let us know if you are able to repeat it once we get it released.

    Leave a comment:


  • derbbre
    replied
    I'm seeing this, too. If I start a session, and even if I wait for comparison to complete, the app won't hide.

    Oddly, if I create a new window, the app will show/hide properly, even with the original session's window still open.

    Leave a comment:


  • zippy99
    replied
    I've got a few comparison tabs open.

    Leave a comment:


  • Aaron
    replied
    Thanks for this report. We'll look into this. I have managed to reproduce this during a comparison, but have had trouble reproducing from just the Home screen (with no work processing in the background).

    Are you also currently mid-comparison, or have a comparison open, when attempting this?

    Leave a comment:

Working...
X