Announcement

Collapse
No announcement yet.

BUG: Can not handle international characters in FTP

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • cstern
    replied
    fixed in 16750

    Leave a comment:


  • cstern
    replied
    I have sent you an e-mail...

    Leave a comment:


  • Aaron
    replied
    Hello,

    We'll need an updated email showing us the new login and initial directory listing with details enabled (Options, Advanced, "Log Panel" section, Debug messages and FTP Trace enabled). Then after the initial directory, please perform a copy of a file, then Touch that file.

    A new screenshot or two with a wide Timestamp column (showing as much detail as possible, where we show more detail the wider the column is) would also be helpful.

    Thanks. You can email us at support@scootersoftware.com. Please include a link back to this forum thread for our reference.

    Leave a comment:


  • cstern
    replied
    not fixed in 16628

    Leave a comment:


  • cstern
    replied
    Great - this will make online backup of files to a FTP server much easier.

    Leave a comment:


  • ZoŽ
    replied
    This will be fixed in the next release. If you can you should upgrade your server's copy of Pure-FTPd.

    The issue was that Pure-FTPd changed its behavior: it originally expected timestamps in the server's local timezone and that's what BC sends. In 2009 they changed it to expect them in UTC instead. I've added code to detect the version and switch automatically, but more recent releases (2011+) support a different, standardized command, which avoids the guesswork.

    Leave a comment:


  • cstern
    replied
    sure - will do.

    Leave a comment:


  • Aaron
    replied
    Thanks for the report. I think I've reproduced something similar.

    In the future, would it be possible to get a separate forum thread for a new issue? This way, other users could find the thread if they are having the same issue.

    Leave a comment:


  • cstern
    replied
    I can confirm that the problem with Danish characters is fixed in the new build (16447)

    However a new problem has occurred. The time stamp on the FTP server is off by 1 hours and 59 minutes after copying a file to the sever. If I copy from the FTP server to the local host (mac) the time stamp is set correct on the copy (i.e the same).

    A screen shot showing the upload problem is attached.

    Leave a comment:


  • Aaron
    replied
    Thanks. We received the log and will look into it.

    Leave a comment:


  • cstern
    replied
    sent

    Leave a comment:


  • ZoŽ
    replied
    In that case, open the Preferences dialog and on the Advanced tab under "Log Panel", turn on "Debug messages", then connect to the site, upload one of the troublesome files, and then save the log (right click on the log panel) and send a copy to support@scootersoftware.com.

    Leave a comment:


  • cstern
    replied
    no go. Same thing happens as before.

    Leave a comment:


  • ZoŽ
    replied
    Hmm. In that case, try opening the FTP Profiles dialog from the "Beyond Compare" menu, and on the first tab look for the "Encoding" dropdown and try changing it to "Western European (ISO)". You may need to restart BC to make the change take effect.

    Leave a comment:


  • cstern
    replied
    I have tried to make the screen shot but since this is a drop Down menu Alt-PrtScr "flips" the menu back and there will not be anything interesting in the screen shot. The same happens in Jing.

    So I took a photograph instead - looks awful, but I guess it is readable (I also had to "squeeze" the jpg to get it small enough for attachment...)

    Leave a comment:

Working...
X